搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Option to Open instead of Save is gone as of 98.0.1

  • 3 回覆
  • 2 有這個問題
  • 51 次檢視
  • 最近回覆由 Terry

more options

Firefox used to give the option to open a file without saving. Now it saves everything to my downloads folder with no option to just open. (I am aware Firefox used to save the opened files in temp). This causes major clutter in my downloads folder and big disruptions to my work flow. Sometimes I just want to view the file and not save it to my working folder (downloads).

Is there a workaround to save to opened files in temp and the saved files to download?

Does Firefox give 2 different "save to" options? One option for a location to save downloaded files and one option for a location to save opened files?

Firefox used to give the option to open a file without saving. Now it saves everything to my downloads folder with no option to just open. (I am aware Firefox used to save the opened files in temp). This causes major clutter in my downloads folder and big disruptions to my work flow. Sometimes I just want to view the file and not save it to my working folder (downloads). Is there a workaround to save to opened files in temp and the saved files to download? Does Firefox give 2 different "save to" options? One option for a location to save downloaded files and one option for a location to save opened files?

所有回覆 (3)

more options

I too find this extremely annoying. I regularly download .csv data files from the National Center for Education Statistics for work and I need to open them directly without saving. I generally do not want these files saved as they are purely temporary. Please return the traditional download box with the "Open File" option.

As a workaround in the meantime, go to about:config and change browser.download.improvements_to_download_panel from true to false. This will bring back the traditional window for now. Hopefully this helps others who find this and are as annoyed as I.

"Improvements"... Right

more options

I'm experiencing this issue, too. I prefer to open most downloads, instead of saving.

more options

I haven't tried this but it evidently works if you want to save files you open to your temp folder. In Settings > General > Files and Applications > Downloads, choose Save to {your temp folder} then re-select Always ask you where to save files. (See the link below, remove the blank space.)

https://www.reddit. com/r/firefox/comments/trnirr/a_work_around_for_open_with_option_for_downloads/