搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

.qfx and .ofx download bug after v98 update

  • 2 回覆
  • 1 有這個問題
  • 56 次檢視
  • 最近回覆由 steelbanger

more options

When downloading financial data to Moneydance software, the download correctly opens Moneydance and update data file correctly, but after v98 Firefox update a second identical .qfx file is downloaded to my desktop which I then have to securely delete as a redundant file on my PC.... This is new behavior, has always worked perfectly previously. Firefox settings under Files and Application header are as follows: Downloads: Save files to Desktop Applications: Actions are set to use Moneydance.exe for all OFX and QFX financial data

The extra file showing up on my desktop is new and unwanted. It seems to be unneeded as it can be deleted without any obvious effect and no loss of data in Moneydance

When downloading financial data to Moneydance software, the download correctly opens Moneydance and update data file correctly, but after v98 Firefox update a second identical .qfx file is downloaded to my desktop which I then have to securely delete as a redundant file on my PC.... This is new behavior, has always worked perfectly previously. Firefox settings under Files and Application header are as follows: Downloads: Save files to Desktop Applications: Actions are set to use Moneydance.exe for all OFX and QFX financial data The extra file showing up on my desktop is new and unwanted. It seems to be unneeded as it can be deleted without any obvious effect and no loss of data in Moneydance

被選擇的解決方法

Obviously this is a delayed response, but... what you are seeing reflects this change in Firefox 98.

  • before Fx98: "Open with [relevant application]" saved the file in the Windows system Temp folder
  • starting in Fx98: "Open with [relevant application]" saves the file in your default downloads folder (the one next to "Save files to:" on the Settings page)

This change addressed problems with data loss for users who could not re-download files they forgot to save after they were removed from the Temp folder. However, now users who preferred those files to be "out of sight, out of mind" are faced with the task of cleaning them up manually.

It's not clear whether we will get the option to go back to using the system Temp folder.

Workaround What I'm doing for now is this set of settings:

(1) Change the default download folder to a "temp" folder I created (2) Set Firefox to always ask where I want to save a file so I can choose a real folder when I want to keep the file

On the Settings page, it looks like this:

從原來的回覆中察看解決方案 👍 0

所有回覆 (2)

more options

選擇的解決方法

Obviously this is a delayed response, but... what you are seeing reflects this change in Firefox 98.

  • before Fx98: "Open with [relevant application]" saved the file in the Windows system Temp folder
  • starting in Fx98: "Open with [relevant application]" saves the file in your default downloads folder (the one next to "Save files to:" on the Settings page)

This change addressed problems with data loss for users who could not re-download files they forgot to save after they were removed from the Temp folder. However, now users who preferred those files to be "out of sight, out of mind" are faced with the task of cleaning them up manually.

It's not clear whether we will get the option to go back to using the system Temp folder.

Workaround What I'm doing for now is this set of settings:

(1) Change the default download folder to a "temp" folder I created (2) Set Firefox to always ask where I want to save a file so I can choose a real folder when I want to keep the file

On the Settings page, it looks like this:

more options

Thank you very much. Good to know why it’s happening and I have had a file go missing occasionally and unable to redownload. Will duplicate your work around. Easy enough to empty that folder occasionally, but still an extra step in choosing download location. Be nice to have the option of the Temp Folder. Thanks