搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

what are the configuration requires for autocomplete work correctly.

  • 1 回覆
  • 1 有這個問題
  • 17 次檢視
  • 最近回覆由 d.dodiya

more options

Hello Team,

I am working on form submit feature in one of project, and for that I set autocomplete='on' at form level, but I am not able see the autocomplete feature when I try submit form second time, I want to see previous input value as a suggestion to user so if he/she wants to use the same session input values if they want to use it.

I set this below kind of code inside my one of form so that it will allow user to show previous input values as a suggestion, this code works correctly and show autocomplete suggestion to user in Chrome and Edge browser but when I try to run the web form in Firefox It is not showing me autocomplete suggestion which entered previously. so could you help me out and provide some suggestion what are the things I missed here?

<input id="name"

               class="cell"
               type="text"
               list="autocompleteOff"
               autocomplete="name"               
/>

I tried below things but no luck.

  1. https://support.mozilla.org/en-US/kb/control-whether-firefox-automatically-fills-forms
  2. https://support.mozilla.org/en-US/questions/1321000


Any suggestion or help would be helpful to fix this issue.

Thanks!

Hello Team, I am working on form submit feature in one of project, and for that I set autocomplete='on' at form level, but I am not able see the autocomplete feature when I try submit form second time, I want to see previous input value as a suggestion to user so if he/she wants to use the same session input values if they want to use it. I set this below kind of code inside my one of form so that it will allow user to show previous input values as a suggestion, this code works correctly and show autocomplete suggestion to user in Chrome and Edge browser but when I try to run the web form in Firefox It is not showing me autocomplete suggestion which entered previously. so could you help me out and provide some suggestion what are the things I missed here? <input id="name" class="cell" type="text" list="autocompleteOff" autocomplete="name" /> I tried below things but no luck. # https://support.mozilla.org/en-US/kb/control-whether-firefox-automatically-fills-forms # https://support.mozilla.org/en-US/questions/1321000 Any suggestion or help would be helpful to fix this issue. Thanks!

所有回覆 (1)

more options

I also tried with this but no luck. <input id="name" class="cell" type="text" autocomplete="name" />