搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How to disable all address bar features ?

  • 2 回覆
  • 1 有這個問題
  • 171 次檢視
  • 最近回覆由 benoit12

more options

I have found a few pages about address rewriting; how do I disable them all ? - searching single word into google (type "keyw" in about:config to disable it) - hiding http when not using https - trying to add "www" and ".com" around a single word when the word did not resolve

I consider most of them as security issues for various reasons.

And when editting an URL, I want firefox to keep showing the full url as it was invoqued; not add https randomly, or removing http other days. And the more I disable some, the more new ones appear.

I have found a few pages about address rewriting; how do I disable them all ? - searching single word into google (type "keyw" in about:config to disable it) - hiding http when not using https - trying to add "www" and ".com" around a single word when the word did not resolve I consider most of them as security issues for various reasons. And when editting an URL, I want firefox to keep showing the full url as it was invoqued; not add https randomly, or removing http other days. And the more I disable some, the more new ones appear.

被選擇的解決方法

You can set browser.urlbar.formatting.enabled to false on the about:config page to disable the highlighting of the domain and see the full URL more clearly. You can set browser.urlbar.trimURLs to false on the about:config page to see the http: protocol on the location bar and in the pop-up if you hover a link.

For the www and com fixup you can check the browser.fixup.alternate prefs.

從原來的回覆中察看解決方案 👍 1

所有回覆 (2)

more options

選擇的解決方法

You can set browser.urlbar.formatting.enabled to false on the about:config page to disable the highlighting of the domain and see the full URL more clearly. You can set browser.urlbar.trimURLs to false on the about:config page to see the http: protocol on the location bar and in the pop-up if you hover a link.

For the www and com fixup you can check the browser.fixup.alternate prefs.

more options

other keys: browser.fixup.alternate.enabled => false browser.fixup.fallback-to-https => false keyword.enabled => false ( initiate google search if name could not be resolved)

cor-el many thanks, at last a browser behaviour that feels fine for me.