搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

tumblr is broken on Firefox

more options

For several days now, tumblr hasn't been working properly on Firefox. The number that pops up to show how any new notifications I've gotten is frozen at 23. I don't get notifications if I get a new ask or to say how many new posts are on the dashboard. I can receive new asks but I cannot answer them and I cannot send them myself. I can receive direct messages, but I can't send them. I've cleared my cache/cookies. I've ended and started several new sessions. I've turned off XKit, Privacy Badger, HTTPS Everywhere, and uBlock Origin. None of that has fixed the problem. These issues are only happening on Firefox. I logged in on Microsoft Edge and tumblr worked just fine.

所有回覆 (2)

more options

I don't have a Tumblr account to test with, but possibly it is a cookie-related issue. Let me elaborate.

Firefox 96 changed some of its SameSite/cross-site cookie handling to work like Chrome and Edge. However, various sites that work with Chrome/Edge do not work with Firefox now, possibly because they are sending different cookies to different browsers. Problems have been reported on Bing, Canvas/Kaltura, and Popmoney.

To test whether this is the problem, you can temporarily roll back the main change to the Firefox 95 setting. This requires going under the covers:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste laxByDefault and pause while the list is filtered

(C) Double-click the network.cookie.sameSite.laxByDefault preference to switch the value from true to false

Most likely, that will take effect immediately, but in some cases, you might need to clear existing cookies for the site or quit Firefox and start it up again.

Hopefully we will get a better understanding of how to set site-specific exceptions in the future so users can benefit from higher security on compatible sites.

有幫助嗎?

more options

jscher2000 said

I don't have a Tumblr account to test with, but possibly it is a cookie-related issue. Let me elaborate. Firefox 96 changed some of its SameSite/cross-site cookie handling to work like Chrome and Edge. However, various sites that work with Chrome/Edge do not work with Firefox now, possibly because they are sending different cookies to different browsers. Problems have been reported on Bing, Canvas/Kaltura, and Popmoney. To test whether this is the problem, you can temporarily roll back the main change to the Firefox 95 setting. This requires going under the covers: (A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. (B) In the search box in the page, type or paste laxByDefault and pause while the list is filtered (C) Double-click the network.cookie.sameSite.laxByDefault preference to switch the value from true to false Most likely, that will take effect immediately, but in some cases, you might need to clear existing cookies for the site or quit Firefox and start it up again. Hopefully we will get a better understanding of how to set site-specific exceptions in the future so users can benefit from higher security on compatible sites.

I gave it a try, cleared out my cookies again, and restarted Firefox, and there wasn't any change, unfortunately. Thanks, though.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題