搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 96.0.2 home screen color

  • 7 回覆
  • 1 有這個問題
  • 41 次檢視
  • 最近回覆由 AIVAS

more options

I saw this posted: (A) Right-click context menus, toolbar drop-down panels Starting in Firefox 89, these would flip to a dark background if the text on the inactive/background tabs was white or light. Firefox 96 has extended this adaptation to more parts of the browser. As far as I know, the only built-in way to avoid this is to change your toolbar theme to one with dark text on the inactive/background tabs. (The other way is the not-officially-supported userChrome.css file route.)

OK, I have been using a "not-officially-supported userChrome.css file" for quite sometime. Every 4th or 5th update (sic) screws it up. Apparently the latest (96.0.2) "looks" at my toolbars, makes an (erroneous) assumption and turns the main part of the home screen to black.

Not useful!

Suggestions to override Firefox's (less than helpful) assumption?

被選擇的解決方法

On that Google page, click the 'Settings' link at the bottom right. On my computer, the last setting is "Dark theme: Off". I'm reluctant to click that because I don't want it to change to On but perhaps that's what you need to do.

從原來的回覆中察看解決方案 👍 0

所有回覆 (7)

more options

Hi AIVAS, I'm guessing you mean "without switching my toolbar theme to one with dark text."

In one of the many threads, there was a suggestion to override the color-scheme property but I've lost track of where you need to apply it.

https://developer.mozilla.org/docs/Web/CSS/color-scheme

Maybe there is something on https://www.reddit.com/r/FirefoxCSS/ .

有幫助嗎?

more options

Thank you for your quick reply. I believe we've posted before or I've just read your posts.

The last time I had to "recover" from a FF update was Feb. of 2019. I managed to fight my way through to my current userChrome file. I'd hate to have to do that again. (My programming days ended about 2 decades ago.)

I like the "dark" toolbars with sort-of neon text, but the dark desktop window screen for some reason is hard on my aging eyes. It occurs to me that somewhere in my userChrome file, I may be able to make the desktop window white with, essentially, black text.

BTW, 96.0.02 made a 2 day-old tab my default home page. I did figure that one out this morning. It also lost one of my custom "Sounds". I think I've replaced that too.

I've looked at:

    https://developer.mozilla.org/docs/Web/CSS/color-scheme 
    Maybe there is something on https://www.reddit.com/r/FirefoxCSS/ .

but don't see anything useful there. I will look them over again tomorrow. Maybe I'll remember more about my userChrome file.

有幫助嗎?

more options

I doubt an older userChrome.css with have the color-scheme property; I think it has only become relevant with Proton.

有幫助嗎?

more options

What do you mean by "home screen"? I have code in userContent.css which changes the colours of browser pages (about, chrome).

有幫助嗎?

more options

What do you mean by "home screen"? I have code in userContent.css which changes the colours of browser pages (about, chrome). I use Google as my default search:

https://www.google.com/webhp?hl=en&ictx=2&sa=X&ved=0ahUKEwjq4fa89cL1AhU5TTABHfbFAiwQPQgI


As I understand the nomenclature, my screen set-up is, top down:

(Warning, my wife never agrees with my descriptions of colors.)

Firefox Menu Bar – very black with neon green text Tabs – the “in use” tab is dark grey with yellow text; other tabs are dark grey with red text Address Bar – dark grey with green text; URL bar and search bar are white Bookmarks Toolbar (currently 2 lines) – dark grey with green text

I am calling the “main” screen (contains the Google logo and search bar) my “home screen”. FF 96.0.1 changed this to a “not quite” black. Searches have the same “black” with powder blue and white text. I would prefer old white with black text. I would not object to trying other colors.

I have made no effort to look into Proton.

有幫助嗎?

more options

選擇的解決方法

On that Google page, click the 'Settings' link at the bottom right. On my computer, the last setting is "Dark theme: Off". I'm reluctant to click that because I don't want it to change to On but perhaps that's what you need to do.

有幫助嗎?

more options

So simple!

Thank you!

Question (you do not have to answer): UK or Aussie?

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題