搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

recently started getting SSL_ERROR_RX_MALFORMED_SERVER_HELLO error after a while of using youtube.

  • 2 回覆
  • 3 有這個問題
  • 17 次檢視
  • 最近回覆由 cor-el

more options

For the last week or so, I've started getting an error page with SSL_ERROR_RX_MALFORMED_SERVER_HELLO message when I try to use Youtube. It happens randomly after a while of surfing the net, including using youtube, and no amount of refreshing or reopening the tab would help, I keep getting this error when trying to access Youtube. Only closing and reopening Firefox solves the problem, until the next time. Its so random, it would be working fine and then I refresh or go to another clip and get the error. (Latest version of FF and using W10 on an Asus Rog Stryx laptop.) Help please? Thank you.

For the last week or so, I've started getting an error page with SSL_ERROR_RX_MALFORMED_SERVER_HELLO message when I try to use Youtube. It happens randomly after a while of surfing the net, including using youtube, and no amount of refreshing or reopening the tab would help, I keep getting this error when trying to access Youtube. Only closing and reopening Firefox solves the problem, until the next time. Its so random, it would be working fine and then I refresh or go to another clip and get the error. (Latest version of FF and using W10 on an Asus Rog Stryx laptop.) Help please? Thank you.

所有回覆 (2)

more options

Quite a few people seem to have had this problem.

The solution boils down to a few about:config tweaks.

WARNING from the moderator team: Changing Firefox pref from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing.

Please read Firefox advanced customization and configuration options to learn more.

Try these one at a time, as the top one seemed to solve the most people's problems, but you may also need to try the lower ones. I can only be sure that the top one doesn't break things.

security.tls.version.max => 3 security.osclientcerts.autoload => true security.tls.hello_downgrade_check => false

有幫助嗎?

more options

Best is to leave security.tls.version.max at its default setting (3) because '2' disables TLS 1.3 (3:TLS 1.2; 4:TLS 1.3).

You can try to disable DNS over HTTPS.security.tls.version.max

Are you using a proxy or VPN ?

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

See also:

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題