搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Using Bing on Firefox

  • 10 回覆
  • 1 有這個問題
  • 46 次檢視
  • 最近回覆由 mrshvd3

more options

When I would go into Bing, I would go into settings and change from "Moderate" to "Strict"; I would also uncheck "Search Suggestions" so suggestions don't fill in as I type. Then I would click "Save". Until recently, these settings held with no problem. Now after I click "Save" and go back to the main screen in Bing (or come back to Bing after being somewhere else), I'm back to "Moderate" and suggestions fill in as I type. Microsoft claims this is Firefox's issue and needs to be fixed at Firefox's end. Others are posting on Microsoft's answers forums, some also using Firefox, but not all. I love Firefox and I'm not changing to something else, so can you tell me how this Bing issue might be fixed? Thank you.

When I would go into Bing, I would go into settings and change from "Moderate" to "Strict"; I would also uncheck "Search Suggestions" so suggestions don't fill in as I type. Then I would click "Save". Until recently, these settings held with no problem. Now after I click "Save" and go back to the main screen in Bing (or come back to Bing after being somewhere else), I'm back to "Moderate" and suggestions fill in as I type. Microsoft claims this is Firefox's issue and needs to be fixed at Firefox's end. Others are posting on Microsoft's answers forums, some also using Firefox, but not all. I love Firefox and I'm not changing to something else, so can you tell me how this Bing issue might be fixed? Thank you.

所有回覆 (10)

more options

I have seen several reports of the same issue so it may be a problem with that website. I assume you are retaining cookies and site settings.

有幫助嗎?

more options

Bing has been sending different cookies to Chrome and Firefox. Now that Firefox 96 wants its cookies like Chrome, Bing has not yet caught up. Until they do, here is the workaround to allow settings to save:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste laxByDefault and pause while the list is filtered

Firefox should list two matching preferences:

  • network.cookie.sameSite.laxByDefault
  • network.cookie.sameSite.laxByDefault.disabledHosts

(C) Double-click the network.cookie.sameSite.laxByDefault.disabledHosts preference to display an editing field, and enter www.bing.com and then press Enter or click the blue check mark button to save the change.

Can you save changes on Bing after that?

有幫助嗎?

more options

TNorth said

I have seen several reports of the same issue so it may be a problem with that website. I assume you are retaining cookies and site settings.

I am retaining cookies, but not the Bing site settings. Everything else, yes. All other sites are fine. Is that what you mean?

有幫助嗎?

more options

jscher2000 said

Bing has been sending different cookies to Chrome and Firefox. Now that Firefox 96 wants its cookies like Chrome, Bing has not yet caught up. Until they do, here is the workaround to allow settings to save: (A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. (B) In the search box in the page, type or paste laxByDefault and pause while the list is filtered Firefox should list two matching preferences:
  • network.cookie.sameSite.laxByDefault
  • network.cookie.sameSite.laxByDefault.disabledHosts
(C) Double-click the network.cookie.sameSite.laxByDefault.disabledHosts preference to display an editing field, and enter www.bing.com and then press Enter or click the blue check mark button to save the change. Can you save changes on Bing after that?

Hi, jscher2000 --

There are those of us who, even after some years, are not computer literate. And I'm afraid you've hit into one. I'm reading your reply (thank you for it), but understand very little of it. Your directions are good, I've no doubt, but I don't know what it means or exactly where to type the things you've instructed. One other thing -- I don't know if this makes any difference, but my OS is Windows 7 in case any of it wouldn't work as a result. You mentioned that "Bing has not yet caught up" -- meaning that maybe they will. I may have to wait for them to -- otherwise, I'm completely confused as to how to do what you've recommended. Thank you very much for your time; it is appreciated.

有幫助嗎?

more options

jscher2000 thank you that work

有幫助嗎?

more options

mrshvd3 said

jscher2000 said

Bing has been sending different cookies to Chrome and Firefox. Now that Firefox 96 wants its cookies like Chrome, Bing has not yet caught up. Until they do, here is the workaround to allow settings to save: (A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. (B) In the search box in the page, type or paste laxByDefault and pause while the list is filtered Firefox should list two matching preferences:
  • network.cookie.sameSite.laxByDefault
  • network.cookie.sameSite.laxByDefault.disabledHosts
(C) Double-click the network.cookie.sameSite.laxByDefault.disabledHosts preference to display an editing field, and enter www.bing.com and then press Enter or click the blue check mark button to save the change. Can you save changes on Bing after that?

Hi, jscher2000 --

There are those of us who, even after some years, are not computer literate. And I'm afraid you've hit into one. I'm reading your reply (thank you for it), but understand very little of it. Your directions are good, I've no doubt, but I don't know what it means or exactly where to type the things you've instructed. One other thing -- I don't know if this makes any difference, but my OS is Windows 7 in case any of it wouldn't work as a result. You mentioned that "Bing has not yet caught up" -- meaning that maybe they will. I may have to wait for them to -- otherwise, I'm completely confused as to how to do what you've recommended. Thank you very much for your time; it is appreciated.

There is a built-in page that you need to open by typing or pasting about:config in the address bar. It's not so different from typing or pasting any other text into the address bar to open a page. Hopefully once you have the page open it will make sense from there. Please refer to the Configuration Editor article I linked earlier for more information.

有幫助嗎?

more options

I heard from a Firefox user with the same problems on Bing. He said he did a system restore to go from Update 96.0.1 back to 95.0.2 and the problems were gone. Not exactly my favorite solution -- I'd rather see the latest update corrected.

有幫助嗎?

more options

System restore is unnecessary when we have a setting.

The developers are testing a patch that will have Firefox identify itself to Bing as Chrome. Hopefully MS will update Bing soon so that isn't necessary.

有幫助嗎?

more options

I hope so, too. I prefer Bing to Google or Yahoo, and I much prefer Foxfire to anything else. Let's hope for that update soon.

有幫助嗎?

more options

jscher2000 said

System restore is unnecessary when we have a setting. The developers are testing a patch that will have Firefox identify itself to Bing as Chrome. Hopefully MS will update Bing soon so that isn't necessary.

Eureka! Hadn't tried in a few days to adjust settings on Bing, but tried it this morning and it worked! Just hope it stays that way now! Thank you again for your replies.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題