搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox userChrome.css - Hide address bar

  • 3 回覆
  • 1 有這個問題
  • 1105 次檢視
  • 最近回覆由 serhumanos

more options

Hello! I am using the userChrome.css file to hide the nav bar (# nav-bar) and show it when hovering the tabs.

The following code works a bit, but when I open the developer tools they overlap.

# nav-bar {
   z-index: -1;
}

# navigator-toolbox: hover # nav-bar {
   z-index: 1;
   background-color: rgba (0,0,0,0.8)! important;
}

#browser {
   margin-top: -45px;
}

Any advice to achieve the expected functionality? Thank you

gif showing the problem: https://s10.gifyu.com/images/firefox-customization-problem.gif

Hello! I am using the userChrome.css file to hide the nav bar (# nav-bar) and show it when hovering the tabs. The following code works a bit, but when I open the developer tools they overlap. <pre> # nav-bar { z-index: -1; } # navigator-toolbox: hover # nav-bar { z-index: 1; background-color: rgba (0,0,0,0.8)! important; } #browser { margin-top: -45px; } </pre> Any advice to achieve the expected functionality? Thank you gif showing the problem: https://s10.gifyu.com/images/firefox-customization-problem.gif
附加的畫面擷圖

由 serhumanos 於 修改

被選擇的解決方法

thanks to @jscher2000 for his hint, In reddit-firefoxCss I got the code

https://www.reddit.com/r/FirefoxCSS/comments/rcogwz/comment/hnzf5rg

#nav-bar {
  /* customize this value. */
  --navbar-margin: -44px;

  margin-top: var(--navbar-margin);
  margin-bottom: 0;
  z-index: -100;
  transition: all 0.3s ease !important;
  opacity: 0;
  background-color: rgba(0,0,0,0.8) !important;
}

#navigator-toolbox:focus-within > #nav-bar,
#navigator-toolbox:hover > #nav-bar
{
  margin-top: 0;
  margin-bottom: var(--navbar-margin);
  z-index: 100;
  opacity: 1;
}
從原來的回覆中察看解決方案 👍 0

所有回覆 (3)

more options

(sorry I don't know how to delete this "answer")

由 serhumanos 於 修改

more options

Hi, you can use <pre> before and </pre> after your CSS to avoid the forum mistaking it for wikitext.

Probably you need to inject some padding at the top of the dev tools and just waste that space. A good site for advanced CSS tweaking is https://www.reddit.com/r/FirefoxCSS/

more options

選擇的解決方法

thanks to @jscher2000 for his hint, In reddit-firefoxCss I got the code

https://www.reddit.com/r/FirefoxCSS/comments/rcogwz/comment/hnzf5rg

#nav-bar {
  /* customize this value. */
  --navbar-margin: -44px;

  margin-top: var(--navbar-margin);
  margin-bottom: 0;
  z-index: -100;
  transition: all 0.3s ease !important;
  opacity: 0;
  background-color: rgba(0,0,0,0.8) !important;
}

#navigator-toolbox:focus-within > #nav-bar,
#navigator-toolbox:hover > #nav-bar
{
  margin-top: 0;
  margin-bottom: var(--navbar-margin);
  z-index: 100;
  opacity: 1;
}