搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Consistent "Trouble find that site" Errors on Windows 11

  • 15 回覆
  • 1 有這個問題
  • 128 次檢視
  • 最近回覆由 FredMcD

more options

Recently I upgraded my Windows 10 to Windows 11 and since doing so, I've had consistent errors while browsing the web on Firefox. Most notably the "Humm. We're having trouble finding that site." error message.

For example, when visiting, say Verizon.com, the tab will display the aforementioned error to which I press Try Again and the website loads correctly every-time. No hiccups on the refresh.

I've tried the following:

  1. I've performed a completely clean uninstall of Firefox and then reinstall
  2. Cleared all browser history/cache
  3. Removed all extensions
  4. Disabled IPv6, HTTPS Over DNS, No Proxy
  5. Ran through Firefox's troubleshooting
  6. Used Firefox Troubleshooting Mode in the Browser
  7. Tested that the problem does not happen while using Edge

I've never had a single problem on Windows 10 with Firefox. Curious if others are experiencing the same issues and if there are any fixes. Nothing else on the PC has changed.

  • Windows 11 21H2 2200.348
  • Network driver is the latest Win11 edition
  • Firefox 95
Recently I upgraded my Windows 10 to Windows 11 and since doing so, I've had consistent errors while browsing the web on Firefox. Most notably the "Humm. We're having trouble finding that site." error message. For example, when visiting, say Verizon.com, the tab will display the aforementioned error to which I press '''Try Again''' and the website loads correctly every-time. No hiccups on the refresh. I've tried the following: # I've performed a completely clean uninstall of Firefox and then reinstall # Cleared all browser history/cache # Removed all extensions # Disabled IPv6, HTTPS Over DNS, No Proxy # Ran through Firefox's troubleshooting # Used Firefox Troubleshooting Mode in the Browser # Tested that the problem does not happen while using Edge I've never had a single problem on Windows 10 with Firefox. Curious if others are experiencing the same issues and if there are any fixes. Nothing else on the PC has changed. * Windows 11 21H2 2200.348 * Network driver is the latest Win11 edition * Firefox 95
附加的畫面擷圖

被選擇的解決方法

So I've been quiet over the past few days because of a lot of troubleshooting and I've discovered the root issue.

I narrowed it down all the way to a Root Certificate that BitDefender loads into Windows and Firefox seems to then reload these into the browser. BitDefender uses this Root Certificate for the internal firewall.

Long story short, disabling the BitDefender firewall lead to FF not having any issues. To which I reenabled the firewall and the issues immediately reappeared. My only assumption here is that during the Windows 11 Upgrade, something went wrong with that Root Certificate that was always working before and that Edge (Chromium) must not use that certificate at all.

A quick removal of BitDefender and then reinstall of it has seem to have fixed the problem!

Thank you all for the continued support.

從原來的回覆中察看解決方案 👍 1

所有回覆 (15)

more options
more options

The URL to Verizon is meaningless. I've had it happen on countless websites. You name it. Verizon was just an example.

As for the connection certificates, I do use BitDefender AV/Firewall, but this hasn't changed in years. The problems began with the Windows 11 upgrade. In addition to that, if BitDefender was the troublemaker, the same issue (I would assume) happen while using MS Edge, and it does not.

more options

Can you verify your DNS settings? What ip are you using? see screenshot

more options

I'm using Cloudflare DNS on my router. So the PC is referencing my local router for a DNS lookup. I've gone into the router to start using my IPS DNS once more and the problem remains.

While this is a DNS issue and I can see that in Fiddler, there's something else going on where ONLY Firefox is causing a hiccup within Windows 11 and the DNS records.

more options

Let me boot up my Win 11 laptop. I'm also using Cloudflare for DNS. I'm still interested in seeing your results for ipconfig /all. Have you turned off BitDefender to verify it's not causing the issue?

more options

Wireless LAN adapter Wi-Fi:

  Connection-specific DNS Suffix  . : hsd1.nj.comcast.net
  Description . . . . . . . . . . . : Intel(R) Dual Band Wireless-AC 8260
  Physical Address. . . . . . . . . : 
  DHCP Enabled. . . . . . . . . . . : Yes
  Autoconfiguration Enabled . . . . : Yes
  Link-local IPv6 Address . . . . . : 
  IPv4 Address. . . . . . . . . . . : 190.180.100.72(Preferred)
  Subnet Mask . . . . . . . . . . . : 255.255.255.0
  Lease Obtained. . . . . . . . . . : Wednesday, December 8, 2021 22:24:39
  Lease Expires . . . . . . . . . . : Thursday, December 8, 2022 22:24:39
  Default Gateway . . . . . . . . . : 190.180.100.69 <--- Router
  DHCP Server . . . . . . . . . . . : 190.180.100.69
  DHCPv6 IAID . . . . . . . . . . . : 
  DHCPv6 Client DUID. . . . . . . . : 
  DNS Servers . . . . . . . . . . . : 190.180.100.69
more options

Verizon works for me also. see screenshot

more options

Okay, remember that that my problem is not with Verizon. My problem is sporadic behavior with DNS on any website. Verizon was simply an example of a well known domain it happens on. I've seen it happen on Reddit, Facebook, News sites, etc.. Here I am on Verizon no problem, but every couple of tries I will receive that DNS error.

Per BitDefender, I haven't attempted yet to disable it? I certainly could try running without the firewall, but I would have expected the same behavior on Edge if that was the case.

As for the IPCONFIG /ALL

Ethernet adapter Ethernet:

  Connection-specific DNS Suffix  . :
  Description . . . . . . . . . . . : Intel(R) Ethernet Connection (2) I219-V
  Physical Address. . . . . . . . . : 
  DHCP Enabled. . . . . . . . . . . : Yes
  Autoconfiguration Enabled . . . . : Yes
  Link-local IPv6 Address . . . . . : (Preferred)
  IPv4 Address. . . . . . . . . . . : 192.168.1.147(Preferred)
  Subnet Mask . . . . . . . . . . . : 255.255.255.0
  Lease Obtained. . . . . . . . . . : Tuesday, December 7, 2021 5:37:05 PM
  Lease Expires . . . . . . . . . . : Thursday, December 9, 2021 5:30:07 PM
  Default Gateway . . . . . . . . . : 192.168.1.1
  DHCP Server . . . . . . . . . . . : 192.168.1.1
  DHCPv6 IAID . . . . . . . . . . . : 115397982
  DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-29-30-44-08-62-45-B4-F6-39-C3
  DNS Servers . . . . . . . . . . . : 192.168.1.1
  NetBIOS over Tcpip. . . . . . . . : Enabled

Thanks for the continued help on this. It's certainly very troubling and puzzling for my brain. I spend all day working in IT and can't figure out my own issues :)

more options

Did you already flush your DNS? ipconfig /flushdns How about your proxy settings? see screenshot

由 jonzn4SUSE 於 修改

more options

Yeah, flushdns was one of the very first things I did. :( I even just redid it this morning out of hope and I didn't even get through 3 minutes before the error again. Of which a quick refresh or Try Again resolves it.

Proxy hasn't been set either. Even after my clean reinstall of FF, I still set the Proxy to off.

more options

Short of a FF developer taking a look at logs or looking more at this issue, I don't see how this will get fixed at this point.

Either that or I need to do a clean install of Windows 11, which I would assume would annoy most FF users to be fair.

more options

Just for kicks, try an old version of FF to see if you have the same issue.

https://ftp.mozilla.org/pub/firefox/releases/

more options

Note: With some versions of Firefox, the data files are not backward compatible. If there is an issue, create a new profile and we can tell you how to recover the data.

Step one: How do you completely turn off update checks in Firefox v64? You can use a policies.json file to disable updates for all users. https://github.com/mozilla/policy-templates/blob/master/README.md or https://winaero.com/blog/disable-updates-firefox-63-above/

You can use a policies.json file in the distribution folder in the Firefox installation folder instead as also listed in the article, so no need to use GPO keys in the Windows Registry. • https://support.mozilla.org/en-US/kb/customizing-firefox-using-policiesjson ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ You can use the ManualAppUpdateOnly policy in Firefox 87+ to enable only manual updates e.g. via "Help -> About Firefox".

Note that it is important to stay up to date and install the latest security patches.

more options

選擇的解決方法

So I've been quiet over the past few days because of a lot of troubleshooting and I've discovered the root issue.

I narrowed it down all the way to a Root Certificate that BitDefender loads into Windows and Firefox seems to then reload these into the browser. BitDefender uses this Root Certificate for the internal firewall.

Long story short, disabling the BitDefender firewall lead to FF not having any issues. To which I reenabled the firewall and the issues immediately reappeared. My only assumption here is that during the Windows 11 Upgrade, something went wrong with that Root Certificate that was always working before and that Edge (Chromium) must not use that certificate at all.

A quick removal of BitDefender and then reinstall of it has seem to have fixed the problem!

Thank you all for the continued support.

more options

That was very good work. Well Done.

You should inform BitDefender support on this.