搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Online metronome no longer makes sound. I get this message. "Your browser does not support the Web Audio standard. Please update your browser or install a more modern browser such as Google Chrome."

  • 2 回覆
  • 1 有這個問題
  • 15 次檢視
  • 最近回覆由 sonofrest

more options

I go to this page https://www.flutetunes.com/metronome/

I get this message "Your browser does not support the Web Audio standard. Please update your browser or install a more modern browser such as Google Chrome."

I've used this metronome for years on Firefox, but now I get no sound. The metronome seems to be running, but it makes no sound. Help!

附加的畫面擷圖

被選擇的解決方法

Hello,

Please first try the "Private Browsing" mode to reduce the number of extensions affecting the page. If the problem is solved, one of the extensions is inhibiting the audio api, disable all extensions and re-enable each one-by-one to find the culprit.

If not, try Firefox's "Troubleshoot Mode" to check if the extensions allowed in "Private Browsing" are the culprits, It also disables some settings that may be the cause instead. If "Troubleshoot Mode" fixes the issue, do the steps above for checking extensions.

Try Firefox Troubleshoot Mode to see if the problem goes away. Firefox Troubleshoot Mode (previously known as Firefox Safe Mode) is a special diagnostic mode that temporarily turns off hardware acceleration, disables add-ons (extensions and themes) and resets some settings. See the Diagnose Firefox issues using Troubleshoot Mode article for details.

If Firefox is open, you can restart in Firefox Troubleshoot Mode from the Help menu:

  • Click the menu button Fx57Menu, click Help, select Troubleshoot Mode and click Restart in the "Restart Firefox in Troubleshoot Mode?" dialog that opens.

If Firefox is not running, you can start Firefox in Troubleshoot Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Troubleshoot Mode window appears, select "Open".

Fx88TroubleshootMode

If the issue is not present in Firefox Troubleshoot Mode, your problem is probably caused by an extension, theme or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Troubleshoot Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again. (If you can't exit Firefox Troubleshoot Mode, please see Firefox is stuck in Troubleshoot Mode).

If this does not work, you can check to see if the audio api is on in the first place:

WARNING from the moderator team: Changing Firefox pref from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing.

Please read Firefox advanced customization and configuration options to learn more.

Although this is the default and is most likely set, you can use about:config to check if dom.webaudio.enabled is set to true. As said above, and in the warning on the about:config page, changing settings in the advanced preferences may lead to issues, so although this is a relatively safe setting, be careful nonetheless.

從原來的回覆中察看解決方案 👍 1

所有回覆 (2)

more options

選擇的解決方法

Hello,

Please first try the "Private Browsing" mode to reduce the number of extensions affecting the page. If the problem is solved, one of the extensions is inhibiting the audio api, disable all extensions and re-enable each one-by-one to find the culprit.

If not, try Firefox's "Troubleshoot Mode" to check if the extensions allowed in "Private Browsing" are the culprits, It also disables some settings that may be the cause instead. If "Troubleshoot Mode" fixes the issue, do the steps above for checking extensions.

Try Firefox Troubleshoot Mode to see if the problem goes away. Firefox Troubleshoot Mode (previously known as Firefox Safe Mode) is a special diagnostic mode that temporarily turns off hardware acceleration, disables add-ons (extensions and themes) and resets some settings. See the Diagnose Firefox issues using Troubleshoot Mode article for details.

If Firefox is open, you can restart in Firefox Troubleshoot Mode from the Help menu:

  • Click the menu button Fx57Menu, click Help, select Troubleshoot Mode and click Restart in the "Restart Firefox in Troubleshoot Mode?" dialog that opens.

If Firefox is not running, you can start Firefox in Troubleshoot Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Troubleshoot Mode window appears, select "Open".

Fx88TroubleshootMode

If the issue is not present in Firefox Troubleshoot Mode, your problem is probably caused by an extension, theme or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Troubleshoot Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again. (If you can't exit Firefox Troubleshoot Mode, please see Firefox is stuck in Troubleshoot Mode).

If this does not work, you can check to see if the audio api is on in the first place:

WARNING from the moderator team: Changing Firefox pref from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing.

Please read Firefox advanced customization and configuration options to learn more.

Although this is the default and is most likely set, you can use about:config to check if dom.webaudio.enabled is set to true. As said above, and in the warning on the about:config page, changing settings in the advanced preferences may lead to issues, so although this is a relatively safe setting, be careful nonetheless.

有幫助嗎?

more options

Hi Andmagdo,

Thanks for your reply. I went into Troubleshoot Mode, and the sound was back. I then left Troubleshoot Mode, and the sound was gone. It was late in the evening, so I did nothing else. This morning the sound was back - as they say, go figure!

I'm very happy to have the sound back. For now, I'm just going to attribute the snafu to some glitch that I'll probably never understand.

Thanks again for your quick response!

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題