搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Appearance background color issues in Windows 7, since v96.0

  • 3 回覆
  • 1 有這個問題
  • 78 次檢視
  • 最近回覆由 lee.turkstra

more options

I have yet another issue to present that I am 100% certain that the developers bear 100% responsibility as a result of releases 96.0 and 96.01. There is a 0% margin for error on this assessment.

I am not presenting this issue because I require personal assistance. I haven’t done a damn thing wrong. I am presenting this issue, so that it would potentially get noticed by or forwarded to one of the developers, or by a user that happens to relay this issue to them.

I am using Windows 7. Therefore, I am uncertain if the issue extends to Windows 10 and 11. The issue does not affect the browser’s functionality.

In my Windows appearance settings, I have always chosen to have a pale yellow color for the background. It relieves the harshness of the white colored background when I am typing in Word for extended hours. I have had this setting for years and never altered it.

Since 96.0, they finally fixed the Bookmarks lag issue, which was pertinent to Windows 7 users. The Bookmarks issue began as of 92.0. I raised that issue as well, and called out the developers as being solely responsible for that. Unfortunately, whatever the developers did in the 96.0 and 96.01 updates, my pale yellow background setting is now appearing on specific websites that must have a clear background in some parts. In other words, those backgrounds used to appear as white on these specific websites. Here are two examples of commonly-used websites that now are displaying my background color setting instead of white. The NCAA football website and the BBC website.

https://www.ncaa.com/sports/football/fbs

https://www.bbc.com/news

As stated in my Bookmarks complaint, there is a blatant absence of any methodical thought process by its development team. They release far too many updates in any given year. Between the 96.0 and 96.0.1 was less than 24 hours. That’s how you know that these people are clueless what they are doing. Then you have this newly introduced issue as a result of fixing others as of 96.0. It’s a very sad state of affairs over at Mozilla. It appears to be a hopeless situation.

If I wanted my background appearance setting to appear on all websites, all I would have to do is set the “Override the colors specified by the page with your selections above” to “ALWAYS”. I have double checked the color settings in Firefox and confirm that my settings have not altered from default. The override… setting is set to “Only with high contrast themes” and the background color is set to white.

The issue that I just presented is 100% on the developers. Don’t even bother trying to challenge it. I was spot-on with the Bookmarks assessment on blame as well. I only provide accurate assessments on blame.

Here’s some advice for the Mozilla developers. Why not fix this issue and kindly spare us with any further updates for the remainder of the year. You people are doing a pathetic job.

This may be a Windows 7 issue only.

被選擇的解決方法

lee.turkstra said

In my Windows appearance settings, I have always chosen to have a pale yellow color for the background. It relieves the harshness of the white colored background when I am typing in Word for extended hours. I have had this setting for years and never altered it. ... whatever the developers did in the 96.0 and 96.01 updates, my pale yellow background setting is now appearing on specific websites that must have a clear background in some parts.

Your Firefox identifies itself as version 94.0, not 96 (96 would be the Nightly testing release).

It looks like the NCAA and BBC pages do not set a background color for the main story area, so Firefox should use the default color per your settings.

There was a change in Firefox 94 intended to better support high contrast system themes and other Windows accessibility features.

Previously, "Use system colors" was ALWAYS OFF. Now it is ON for Windows by default, and still OFF for Mac and Linux. Since you do not want this, go into Settings > Colors, uncheck the box and see whether that resolves it. A Firefox restart might be needed.

Please let us know your results.

從原來的回覆中察看解決方案 👍 0

所有回覆 (3)

more options

選擇的解決方法

lee.turkstra said

In my Windows appearance settings, I have always chosen to have a pale yellow color for the background. It relieves the harshness of the white colored background when I am typing in Word for extended hours. I have had this setting for years and never altered it. ... whatever the developers did in the 96.0 and 96.01 updates, my pale yellow background setting is now appearing on specific websites that must have a clear background in some parts.

Your Firefox identifies itself as version 94.0, not 96 (96 would be the Nightly testing release).

It looks like the NCAA and BBC pages do not set a background color for the main story area, so Firefox should use the default color per your settings.

There was a change in Firefox 94 intended to better support high contrast system themes and other Windows accessibility features.

Previously, "Use system colors" was ALWAYS OFF. Now it is ON for Windows by default, and still OFF for Mac and Linux. Since you do not want this, go into Settings > Colors, uncheck the box and see whether that resolves it. A Firefox restart might be needed.

Please let us know your results.

more options

Please reply with your feedback to this thread. We are getting other user questions about system colors and need to know whether turning off this checkbox works for you or whether it is broken for you. Thank you.

more options

I first want to say that I haven’t responded until now because I have been busy. There was no intent to be rude to you. I appreciate you sticking with me and still trying to assist me on this other matter regarding color backgrounds.

I thank you for providing that explanation on what Firefox changed in version 94 pertinent to the high contrast aspect.

Unchecking the (use system colors) box apparently resolved the issue. I have not browsed enough websites to verify if other websites that once were OK possibly may not be currently displaying their appropriate colors. I will let you know if I run into an issue on this new setting.

I always know the moment when Firefox does something to bugger up their browser after an update. This box was always checked up until I read your post.

Your assessment was spot-on. I will mark this issue as resolved. You are an asset to the community.

Thank you.