搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

[SOLVED]MP3 and video files starts to play instead of asking to download.

more options

Hello, I have recently noticed that firefox starts playing files where it used to give a prompt on whether to sav or open file. I know I can right click- save link as, but I would like it get the prompt instead, if possible.

-Howard

由 howard_e_frogge 於 修改

被選擇的解決方法

Hi Howard, for certain types of content that Firefox can handle internally, it doesn't bother asking you, it just shows it. Most types of images, audio, and video files are in that category.

There is a setting you could experiment with. This setting prevents Firefox from using its built-in "stand alone" player (i.e., media opened in its own tab) but doesn't affect in-page embedded players. To give it a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste media.play-stand-alone and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

Does that work? If you need to use the stand-alone player in the future, you'll have to flip it back by double-clicking again (or clicking the left-arching reset arrow at the right end of the row).

More info on about:config: Configuration Editor for Firefox.

Note: I suggest bookmarking this thread for future reference in case the name of this preference slips your mind.

從原來的回覆中察看解決方案 👍 1

所有回覆 (3)

more options

In the provided link below, set the 'Always Ask' Action for the 4th step.

https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file#w_changing-download-actions

有幫助嗎?

more options

選擇的解決方法

Hi Howard, for certain types of content that Firefox can handle internally, it doesn't bother asking you, it just shows it. Most types of images, audio, and video files are in that category.

There is a setting you could experiment with. This setting prevents Firefox from using its built-in "stand alone" player (i.e., media opened in its own tab) but doesn't affect in-page embedded players. To give it a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste media.play-stand-alone and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

Does that work? If you need to use the stand-alone player in the future, you'll have to flip it back by double-clicking again (or clicking the left-arching reset arrow at the right end of the row).

More info on about:config: Configuration Editor for Firefox.

Note: I suggest bookmarking this thread for future reference in case the name of this preference slips your mind.

有幫助嗎?

more options

Thank you Yash and jscher! I already set it to "always ask" but it still didnt ask.. Changing "media.play-stand-alone" makes it so it asks me again.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題