搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How to Enable 3rd party cookies for Kaltura Media Application in Firefox Nightly 94.0a1

  • 10 回覆
  • 3 有這個問題
  • 237 次檢視
  • 最近回覆由 cor-el

more options

I am unable to enable 3rd party session cookies, which are required for the Kaltura application, in D2L Brightspace for online education courses in Firefox Nightly 94.0a1.

I have tried Kaltura application specific, and my educational institution specific troubleshooting with no change. I have tried changing settings in Firefox Nightly's Privacy and Security Enhanced Tracking Protections and by Managing Exceptions in Cookies and Site Data with no changes.

On the webpage of my course material there is a message that reads: "It seems your browser is blocking 3rd party session cookies which are required for the Kaltura application. To resolve this issue, please update your settings to allow 3rd party cookies." under Course Tour Video

I have further troubleshot this issue by managing the same exceptions in Google Chrome where the content is working. I have retrieved the relevant content URLs from the Google Chrome browser Kaltura video and cookie info and used them in Firefox Nightly to allow all appropriate exceptions with no changes.

After all troubleshooting, I have took the step of clearing Cookies, Site Data, History and restarting Firefox Nightly with no changes on the course page and met with the same error message.

How can I resolve this, because I would like to use Firefox Nightly as my preferred browser for my course work?

I am unable to enable 3rd party session cookies, which are required for the Kaltura application, in D2L Brightspace for online education courses in Firefox Nightly 94.0a1. I have tried Kaltura application specific, and my educational institution specific troubleshooting with no change. I have tried changing settings in Firefox Nightly's Privacy and Security Enhanced Tracking Protections and by Managing Exceptions in Cookies and Site Data with no changes. On the webpage of my course material there is a message that reads: "It seems your browser is blocking 3rd party session cookies which are required for the Kaltura application. To resolve this issue, please update your settings to allow 3rd party cookies." under Course Tour Video I have further troubleshot this issue by managing the same exceptions in Google Chrome where the content is working. I have retrieved the relevant content URLs from the Google Chrome browser Kaltura video and cookie info and used them in Firefox Nightly to allow all appropriate exceptions with no changes. After all troubleshooting, I have took the step of clearing Cookies, Site Data, History and restarting Firefox Nightly with no changes on the course page and met with the same error message. How can I resolve this, because I would like to use Firefox Nightly as my preferred browser for my course work?
附加的畫面擷圖

所有回覆 (10)

more options

Settings -> Privacy & Security -> Custom tracking protection -> turn off Cookies

or

Click the Shield icon in the URL bar and turn off the Enhanced Tracking Protection for that site.

more options

@TyDraniu

Thank you for your response. Unfortunately I have already tried both options and I am still getting the same error.

more options

Does this work properly in the Release (92) or Beta/DE (93) version ?

Did you try to disable all check boxes in the Enhanced Tracking Protection custom settings (i.e. allow all cookies) ?

Are you possibly using Private Browsing mode ?

Any relevant-looking messages in the Web Console ?

more options

@cor-el

Thank you for you response.

"Does this work properly in the Release (92) or Beta/DE (93) version ?" I have not tried to repeat the issue in the Release (92) or Beta/DE (93) versions. I only use Nightly, but I will give those versions a try.

"Did you try to disable all check boxes in the Enhanced Tracking Protection custom settings (i.e. allow all cookies) ?" I did try this step, and as with all other steps, I deleted cookies, cache, and history, restarted Nightly and still met the same issue.

"Are you possibly using Private Browsing mode ?" I am not using Private Browsing mode. Although, as a troubleshooting step, I tried to login to my course page in Private Browsing mode and still had the same issue.

"Any relevant-looking messages in the Web Console ?" Honestly, I'm not advanced enough at this point to try to use Web Console.

more options

Keep in mind that the Nightly builds are aimed at experienced testers that know how to deal with issues and if necessary can fallback to the current release (or beta) version. It looks that at the moment updates are halted on Nightly (? due to reported crashes) as I haven't seen an update today.

more options

@cor-el

To follow up on your previous question:

"Does this work properly in the Release (92) or Beta/DE (93) version ?"

I tested Release (92) and Beta/DE (93) versions, new installations and it works as intended without having to change Enhanced Tracking Protection settings.

It must be my Nightly installation which has several add-ons and is customized to some degree with CSS.

more options

You can try Nightly with a new profile.

more options

My Firefox just updated to 96.0.2 and I am having the same issue. I do not know what Release (92) or Beta/DE (93) or Nightly versions are, and my update settings are set to automatic. I tried the suggestions in the first post and, like the OP, had no success. I hope someone can help.

more options

Same issue here. Still running 96.0.1 (64-bit) but the message I get is "It seems your browser is blocking 3rd party session cookies which are required for the Kaltura application. To resolve this issue, please update your settings to allow 3rd party cookies." I tired the suggestions described in the previous two posts with no success. Hopefully, someone can help.

more options

There is a change in Firefox 96 related to cookies and insecure sites.

See also:

As a workaround for now you can modify this pref on the about:config page to revert this change.

  • about:config => network.cookie.sameSite.laxByDefault = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.