搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

instances running

  • 3 回覆
  • 1 有這個問題
  • 6 次檢視
  • 最近回覆由 TyDraniu

more options

I have my instances running set to 2. BECAUSE I WANT TO. Please don't try to explain why such and such is better. I am good.

Yet no matter what I tell Firefox, I may have up to 10 instance running with only one window open. Yes, I have the current process limit set to 2. I have the recommended block empty. I have tried it with "use hardware acceleration when available" checked and unchecked. it doesn't matter, Firefox still runs numerous instances..

How do I control this? it is eating up 30% of my memory at times.

所有回覆 (3)

more options

It is quite normal to see more Firefox processes running.

  • process for the main Firefox thread (user interface)
  • one or more content processes, see:
    Settings (Options/Preferences) -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • process for the compositor thread
  • process for extensions
  • process for WebRender when this feature is enabled

You can find the current multi-process state on the Troubleshooting Information page (about:support).

  • "Help -> Troubleshooting Information"
    "Application Basics": Multiprocess Windows
    "Remote Processes" further down

See also the about:memory page for information about the process IDs.

有幫助嗎?

more options

If I set my instances to 2- why is is running more than 2? How do I make it run only 2?

有幫助嗎?

more options

For now you can only limit content processes (not instances). Beside these, there are a lot of different things, Add-ons, GPU, and so on. Everything is enumerated on the about:support#remote-processes page.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題