搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox restoring sessions on startup despite "Restore previous sessions" being unchecked in startup

  • 5 回覆
  • 3 有這個問題
  • 152 次檢視
  • 最近回覆由 FredMcD

more options

Possible bug: I cannot stop Firefox from restoring sessions after restarting computer. Restore previous session is not checked in Settings, browser.sessionstore.resuming_after_os_restart is false, and browser.sessionstore.resume_from_crash is false as well. Ubuntu 20.04, Firefox 91.0.2, only add-on is TreeStyleTabs, but this behavior displays with add-ons disabled.

Possible bug: I cannot stop Firefox from restoring sessions after restarting computer. Restore previous session is not checked in Settings, browser.sessionstore.resuming_after_os_restart is false, and browser.sessionstore.resume_from_crash is false as well. Ubuntu 20.04, Firefox 91.0.2, only add-on is TreeStyleTabs, but this behavior displays with add-ons disabled.

被選擇的解決方法

Are you closing the browser properly? menu > exit - not pressing the X in the corner


You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.


Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

從原來的回覆中察看解決方案 👍 0

所有回覆 (5)

more options

選擇的解決方法

Are you closing the browser properly? menu > exit - not pressing the X in the corner


You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.


Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

more options

Thank you. It appears deleting the sessionstore files has fixed the issue. I would personally say there is still an issue with robustness if Firefox fails into bad behavior if closed using the "X" instead of going through the menus and selecting "Quit."

more options

Glad to help. Safe Surfing.

more options

I have tried all of the above, deleted and reinstalled, refreshed, deleted other files (prefs), and it still tries to restore session when opening. This is on a win10/AMD A10 PC. Is there a registry setting for FF that is not deleted on uninstall?

more options