搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Unable to open hyperlinks in Firefox 91.0.1

  • 7 回覆
  • 1 有這個問題
  • 35 次檢視
  • 最近回覆由 FredMcD

more options

When clicking on a hyperlink in a webpage in Firefox 91.0.1, the link fails to open. If I right click it will open. In Preferences/Settings , Firefox is set as default browser and I have left Open Links in Tabs instead of new windows unchecked (I prefer to open in new window). If I right click on the link I can open in either a new tab or a new window.

This does not happen in Safari. Any ideas?

被選擇的解決方法

senbariki said

As noted, I'm on a Mac running OSX 11.5.1

One of the links was for all systems.


On the problem websites, do this; Delete browsing, search and download history on Firefox {web link}

Remove a single website from your history {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings And Passwords.

從原來的回覆中察看解決方案 👍 0

所有回覆 (7)

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Note: cor-el said

This could be a problem with High Contrast Mode on Mac. See "New" in the release notes. Firefox now automatically enables High Contrast Mode when "Increase Contrast" is checked on MacOS in the Accessibility settings.

Make sure you allow pages to choose their own colors.

  • Settings -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

有幫助嗎?

more options

Fred, Thanks for responding so quickly. Unfortunately, the suggestions did not solve the problem. Yes, the problem still exists in safe mode. I do have High Contrast Mode enabled on my Mac. Switching to"Never" in Settings -> Colors did not do anything. I'm running OSX 11.5.1 and as noted, Firefox 90.0.1.

My wife's Mac is running OSX 10.14.6 and Firefox 90.0 and does not have HIgh Contrast Mode enabled. No problems clicking on same hyperlinks I've been testing on my Mac and having the link open as usual. Her Color setting is "Only with high contrast themes". Argh!

有幫助嗎?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

Starting Any Computer In Safe Mode (web link) Free Online Encyclopedia

https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

https://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10/ +++++++++++++++++++++++++++++++++++++++++++++++ If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system.

As a test, disable your protection programs.

有幫助嗎?

more options

Fred, As noted, I'm on a Mac running OSX 11.5.1, so the links to Windows don't apply in my case. I did try starting in Safe Mode on the Mac but the problem still exists. I also tried disabling protection but the problem still exists. I originally noticed the problem on one particular website that I visit a lot, and then found it on a couple of others, but the vast majority work fine.

I have to assume that it is something with the websites that I can't open the embedded links with a single click only that don't get along with some setting or other on my Mac/Big Sur because as I noted, this doesn't happen on my wife's Mac running Mojave.

i appreciate you attempting to get this solved, but don't spend any more time trying as I'll just live with having to right click and select Open In New Window in the drop down menu for any websites that exhibit this problem. It's not that big a deal, just a minor annoyance. Thanks again, Barry

有幫助嗎?

more options

選擇的解決方法

senbariki said

As noted, I'm on a Mac running OSX 11.5.1

One of the links was for all systems.


On the problem websites, do this; Delete browsing, search and download history on Firefox {web link}

Remove a single website from your history {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings And Passwords.

有幫助嗎?

more options

Fred, I marked my problem as solved, which it has been, but used the one-step method as it was quicker. https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox Clear cookies for the current website 1. Click the padlock a the left of the address bar 2. Click cookies and site data. Voila! Now able to single click on hyperlinks within the website.

Thanks for persevering to work on this problem!

有幫助嗎?

more options

Glad to help. Safe Surfing.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題