搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Remove autocomplete entries

  • 11 回覆
  • 1 有這個問題
  • 35 次檢視
  • 最近回覆由 Jordan

more options

Hi,

Using FF 91, I'm unable to remove autocomplete entries in the url field. I'm following the instructions from this page:

https://support.mozilla.org/en-US/questions/1300485

and the KB entry on which this page is based: http://kb.mozillazine.org/Deleting_autocomplete_entries

On a Windows 10 PC, I've tried using both the Delete key and the Shift+Delete but the entry I'm trying to get rid of keeps coming back. I also removed all cookies associated with this url.

Would greatly appreciate your help.

Jordan

被選擇的解決方法

Try to rename/remove places.sqlite in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for issues with the places.sqlite and favicons.sqlite databases in the Firefox profile folder.

  • use the "Places Database" -> "Verify Integrity" button on the "Help -> More Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox or reboot and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder with Firefox closed. Firefox will rebuild places.sqlite and restore the bookmarks from the most recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created
  • you lose the history when a new places.sqlite is created

You may have to restore an older bookmarks backup in the bookmarkbackups folder via the Bookmarks Manager (Library).

See also:

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

從原來的回覆中察看解決方案 👍 0

所有回覆 (11)

more options

If you click on the address bar without typing into it, a drop-down of your Top Sites will be displayed instead. So to remove this entry, you have to remove this page from your top sites.

有幫助嗎?

more options

Thanks, Ty!

But... the site I was trying to remove from the autocomplete is not among the "top sites"...

And, I'm not clear on how to remove "top sites" because the delete (and shift+delete) function doesn't do it. And the I cannot find information on this via the link you provided.

The original question remains: Why am I unable to delete a site that comes up in the address bar by either the Shift+Delete or the Delete -- which is the official method per FF instructions.

Thanks again, J

有幫助嗎?

more options

Jordan, does the page get deleted fine from the history tab ? I understand that your ask is to delete it directly from the address bar, but want to check if this issue is site specific or if there is an issue that needs to be addressed.

I tested this on FF 91.0 on Ubuntu and was able to delete the entry using shift + delete. I will try and check this on FF91 on Windows also and will post my findings.

Thank You

有幫助嗎?

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

有幫助嗎?

more options

Thanks, gnittala!

I was able to remove it from the history drop menu, no problem. Then, using the Delete key or the Shift+Delete, I tried again to delete it from the address bar drop-list: it was visually removed from the list when I clicked, but as soon as I retyped the first four letters again, it came back.

Thanks, cor-el!

Following your advice, I removed the site from the history via the "Forget about [it]..." It was successfully removed from the History (was no longer found when I searched History for it).

But, surprisingly, it is still offered as an autocomplete choice in the address bar.

So... still an annoying problem.

Thank you both again! Jordan

有幫助嗎?

more options

So, even though it was deleted from the address bar (shift + delete) and you selected forget-about-this-site, as you type the URL, the address is showing up in the address bar.

Is this what is happening ? Are you sure that the URL is not coming from a search provider (most likely not, want to check).

Thank You

有幫助嗎?

more options

Yes. This is exactly what's happening.

How do I find out whether it comes from a "search provider?" Google is my default search method; but how can I tell whether it comes from google?

And, it would be unlikely: the offending website is a minor site whose domain name starts with a name shared by many, including one major site, with an added element which makes the url completely different. However, because the first part of the domain name is shared with other domain names, for some reason the autocomplete goes there first, which is very annoying.

However, with google search results ranking, it's extremely unlikely to offer that one site over the one I'm really after, that is known around the world and that I also the one I visit frequently.

Thanks again!

有幫助嗎?

more options

Would it be possible for you to share an example URL where this is happening? I can try to check with similar sites to see if the hypothesis you detailed is what is happening.

But more important is to be sure that there are no remnants of the site you forgot and deleted anywhere in your local profile. Were you able to confirm that the site doesn't show up in the history (menu -> history -> manage history)

Thank You

有幫助嗎?

more options

Sure. Here's the actual offending url: vanguardmotorsales.com/

As you can see, the "vanguard" part is common and shared by lots of other domain names, many that are far more prominent websites.

And, yes, I just rechecked and confirmed that when I search for this url in the search box at top-right of the Manage History window it returns a blank box and says No Items at bottom bar.

Thanks!

有幫助嗎?

more options

選擇的解決方法

Try to rename/remove places.sqlite in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for issues with the places.sqlite and favicons.sqlite databases in the Firefox profile folder.

  • use the "Places Database" -> "Verify Integrity" button on the "Help -> More Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox or reboot and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder with Firefox closed. Firefox will rebuild places.sqlite and restore the bookmarks from the most recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created
  • you lose the history when a new places.sqlite is created

You may have to restore an older bookmarks backup in the bookmarkbackups folder via the Bookmarks Manager (Library).

See also:

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

有幫助嗎?

more options

Thank you cor-el! Problem now solved.

I renamed the places.sqlite file, then found the offending urls in the Bookmarks. (Previously, on advice on this case, I looked for them in History, but they weren't there.) Once removed from Bookmarks, they were no longer offered as autocompletes in the address box.

I was also able to restore the renamed places.sqlite file so I didn't lose my History...

Thank you all for your knowledgeable and thoughtful advice! Jordan

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題