搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox keeps creating a new profile every time it is opened

  • 5 回覆
  • 1 有這個問題
  • 32 次檢視
  • 最近回覆由 cor-el

more options

I am testing FF91esr for deployment later this year. Having a lot of grief with it.

For context; On most of our PCs the profile folder is NOT in the %APPDATA% folder. It lives on a different drive, typically drive F:\

This allows us a lot of freedom to restore a users C:\ drive without messing up the Firefox profile, or losing recent information, for example. We do the same for Thunderbird and several other applications.

The profile.ini file does live in its default location and points to the relavant folder path=F:\Users\<username>\profiles\<profilename> IsRelative=0

We backup a users PC with a comprehensive script which copies the profile.ini and Profiles folder. The group policy is also backed up, and in that policy we have set to use legacy profiles.

When we build a new PC for a user we restore those backups in the hope that the user will take up where they left off. For example, their browser history will be at the point is was when they left the PC.

The whole process is pretty automated. However, with FF91esr I cannot get it to use the folder we backed up. It ignores what's in the profiles.ini file and creates a new profile in the default location, set's it as default and of course sets IsRelative=1.

I tried several combinations of things to try to stop this, but in the end the ONLY way I could get it to use the restored profile was to go to about:profiles, create a new profile, point it to the folder where the restored profile is located, restart using the new browser, then via about:profiles, delete the bogus profile (of course having set the restored profile as default).

I'm not going to sit at 250 PCs doing that. It's crazy.

How can I get FF to use the restored profile folder and stop it endlessly creating new profile folders?

So far I've only tested with clean installs of FF91esr, so this is not an issue with different versions of profiles. But I am concerned over what's going to happen when I update Firefox on a PC...

所有回覆 (5)

more options

Note that is current releases backing up installs.ini might be a good idea as this is a backup for profiles.ini. Also note that that profiles are locked to a specific installation path. See also:

有幫助嗎?

more options

I'm not sure I follow. I did notice the Locked=1, but I thought that was just to prevent the profile being deleted.

  1. I install Firefox 91.0.1 onto a fresh install of Windows.
  2. I Update my GPO, and run gpupdate /force.
  3. I copy my userChrome.css and userContent.css files to the Chrome folder.
  4. I run run Firefox and it creates a profile.
  5. I update my settings, apply any preferences changes via about:config
  6. I close Firefox Edit the profiles.ini and install.ini to make sure they point to F:\ drive
  7. I move the profile folder to the F:\ drive (the .default folder, not the actual "profiles" folder).
  8. I re open it and it creates a new profile.
  9. I close Firefox without doing anything and open it again and it creates a new profile.
  10. I close Firefox without doing anything and open it again and it creates a new profile.

At one point I had 32 profile folders in %APPDATA%\Mozilla\Firefox\Profiles.

This behavior does not occur in any previous version of Firefox I've used.

I deleted all those and started again. This time I left the profiles on the C:\ drive. I did not alter the profiles.ini or install.ini. Same deal, every time I opened Firefox it created a new folder.

  1. Re-installed windows.
  2. I restored a copy of 78.13.0 which is on my F:\ drive, along with the corresponding %APPDATA% folder.
  3. I installed the new GPO templates and updated my policies, ran gpupdate /force.
  4. I installed Firefox 91.0.1 over the top and it upgraded.
  5. I ran Firefox and it did NOT create a new profile. It used the path in profiles.ini, which pointed to F:\
  6. However, I had lost the theme and some add ons. Add ons that were still installed had been disabled.
  7. Updated my settings, about:config preferences, fixed the issues from the upgrade, re-imported my bookmarks which got crunched by the upgrade
  8. Ran Firefox again and it continued to use the correct profile.

Observations: A Clean install of Firefox creates a new profile every time it is run Firefox has to be run at least twice to get the userChrome.css and userContent.css files to kick in Every time I update the GPO it breaks the them, which whilst still installed is broken requiring it to be installed again The profiles.ini file is identical for both scenarios.

--- My profiles.ini file; [Install308046B0AF4A39CB] Default=F:\Users\Tanya\Profiles\ownri05i.default Locked=1

[Profile0] Name=default IsRelative=0 Path=F:\Users\Tanya\Profiles\ownri05i.default Default=1

[General] StartWithLastProfile=1 Version=2 ---

由 citizen1138x 於 修改

有幫助嗎?

more options

Why is it that every time I edit a post it disappears?

有幫助嗎?

more options

I'm sorry, did I offend someone?

有幫助嗎?

more options

Sorry, I seem to have missed your above replies.

Note that if you install a new Firefox then probably a new install hash ([Install308046B0AF4A39CB]) gets created or an existing lock is honored that prevents Firefox from using the locked profile. Thia shouldn't happen if you update an existing installation, but I don't know how Firefox behaves if you use an installer. To avoid such issues you should use a profiles.ini without [Installxxxx] sections and also remove installs.ini. Firefox will still complain if you downgrade a profile and start it with an older Firefox version.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題