搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

links in websites not opening

  • 9 回覆
  • 1 有這個問題
  • 16 次檢視
  • 最近回覆由 FredMcD

more options

This has just started happening

If I click on a link in a website nothing happens. Up until yesterday Firefox would open the link in the same tab, but now it just sits there. If I right click I can open in a new tab, but not in the same tab

I've cleared cache, cookies, etc etc. Shut down and fired up, nothing seems to work.

所有回覆 (9)

more options

Please provide a public link (no password) that we can check out. No Personal Information Please !

more options

I tried several versions of Firefox and had no problem.


Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

I ran in safe mode and the problem isn't there. I then re-started and disabled all extensions one by one and could not isolate the problem - i.e. with all extensions disabled I the problem persisted

more options

It could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

more options

I followed your suggestion and disabled hardware acceleration. It made no difference

more options

Some links can't be opened in the same tab. Are you diverting links to open in the same tab via "browser.link.open_newwindow = 1" ?

Can you open those link in a new tab if you hold the Ctrl key and left-click or middle-click the link ?

more options

OK, so this isn't my website. It's an issue I have using Firefox where links do not open in the same tab. They can open in a new tab OK, just not in the same tab. I don't have the issue using other browsers (such as Chrome and Edge)

more options

mad prof said

I ran in safe mode and the problem isn't there. I then re-started and disabled all extensions one by one and could not isolate the problem
I followed your suggestion and disabled hardware acceleration. It made no difference

That leaves a setting causing the issue.


Use these links to create a new profile. Use this new profile as is. Is the problem still there?

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible

http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles


Type about:profiles<enter> in the address bar.