搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How to disable Master password timeout?

  • 2 回覆
  • 1 有這個問題
  • 15 次檢視
  • 最近回覆由 Alesak

more options

Since couple of months ago, FF started to ask for master password after 30 minutes of inactivity. I have auto-refresh for some tabs which use Basic Authentication. After 30min those tabs stops refreshing and FF opens multiple (5) dialogs for master password. This secondary layer of security is pretty annoying as I have my computer secured on multiple levels by multiple factors already. I am getting very annoyed by this, is there any way to disable this "feature"? I have security.ask_for_password = 0 and signon.masterPasswordReprompt.timeout_ms = 0 but it keeps asking (now bit less often but still does). I just want master password entered once when I start the session and keep it open until I quit the browser.

被選擇的解決方法

It looks like dev version of FF 92 is not requesting PP anymore , FF 91 still does. Probably some already fixed bug. Thanks for the pref explanation.

從原來的回覆中察看解決方案 👍 0

所有回覆 (2)

more options

As far as I know then there isn't a timeout for the Primary Password. You only logout if you cancel a PP prompt.

The signon.masterPasswordReprompt.timeout_ms pref is for reprompting to enter the PP if you had canceled the PP the last time Firefox asked for it because it needed to unlock the logins and this pref defaults to 15 minutes.


  • 1673632 - Support toolkit-wide timeout/expiration of primary password (previously called master password)

(https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

有幫助嗎?

more options

選擇的解決方法

It looks like dev version of FF 92 is not requesting PP anymore , FF 91 still does. Probably some already fixed bug. Thanks for the pref explanation.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題