On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

about:profiles doesn't "Open Directory" from a profile

  • 2 回覆
  • 1 有這個問題
  • 34 次檢視
  • 最近回覆由 SkyHook

more options

Under an "about:profiles" profile, selecting the "Open Directory" button opens my Linux "Document Viewer" with an "Unable…" warning; expected because that's not what Document Viewer is for.

This could be exactly as predicted in my preferences, but I didn't find any means to redirect that button action at a different helper. I expected it to routinely use my default file manager application and this was a surprise. All I could find searching for the issue focuses on URLs which isn't my problem; I can enter (or copy/paste) the displayed path beside that button okay as "file:///…," so I can call that the workaround.

How is this button action set? Is it a simple thing buried somewhere in the settings?

Under an "about:profiles" profile, selecting the "Open Directory" button opens my Linux "Document Viewer" with an "Unable…" warning; expected because that's not what Document Viewer is for. This could be exactly as predicted in my preferences, but I didn't find any means to redirect that button action at a different helper. I expected it to routinely use my default file manager application and this was a surprise. All I could find searching for the issue focuses on URLs which isn't my problem; I can enter (or copy/paste) the displayed path beside that button okay as "file:///…," so I can call that the workaround. How is this button action set? Is it a simple thing buried somewhere in the settings?

被選擇的解決方法

Okay, great first step. After a deprecation warning, it appears both installed file managers are in my returned list of a dozen; gnome.nautilus and elementary.files.

Eureka! The list were only potential recommendations. I see now that it returned a list of options because one wasn't set. Why not, I'm not worried about, but it feels strange. I went back to the command line with the following and now FF launches my favourite file manager as expected.

Thank you very much.

$ gio mime inode/directory org.gnome.Nautilus.desktop Set org.gnome.Nautilus.desktop as the default for inode/directory

從原來的回覆中察看解決方案 👍 0

所有回覆 (2)

more options

Sounds something is broken. You can try this command in a terminal window.

  • gvfs-mime --query inode/directory
more options

選擇的解決方法

Okay, great first step. After a deprecation warning, it appears both installed file managers are in my returned list of a dozen; gnome.nautilus and elementary.files.

Eureka! The list were only potential recommendations. I see now that it returned a list of options because one wasn't set. Why not, I'm not worried about, but it feels strange. I went back to the command line with the following and now FF launches my favourite file manager as expected.

Thank you very much.

$ gio mime inode/directory org.gnome.Nautilus.desktop Set org.gnome.Nautilus.desktop as the default for inode/directory

由 SkyHook 於 修改