搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How do I stop Firefox asking me every time it opens whether I want it to be my default browser. Of course I do!

  • 4 回覆
  • 1 有這個問題
  • 26 次檢視
  • 最近回覆由 gbc723

more options

How do I stop Firefox asking me every time it opens whether I want it to be my default browser. Of course I do!

被選擇的解決方法

If the "Always check if Firefox is the default browser" option is grayed out, you can forcefully and manually change this by entering "about:config" into your Firefox browser's search bar and changing the attribute value through that page.

1) Search up "about:config" in your Firefox search bar.

2) Click on "Accept the risk and continue."

3) Once you're in the page, type in "Shell" into the page's the search bar.

4) Look for "browser.shell.checkDefaultBrowser", the value for this attribute should be "true," double click on it to change it to "false." Exit the page and go about the to "Always check if Firefox is the default browser" option to see if it is still grayed out.

從原來的回覆中察看解決方案 👍 1

所有回覆 (4)

more options

If you are on Windows 10 and would like to set Firefox as your default browser, you can click on the menu button which is represented by three horizontal lines located at the top right corner of Firefox. Click on the "General" options after the dropdown menu appears, you will be redirected to the settings page. Enter "Default" into the search box and a button named "Make Default..." should appear.

Clicking on the make default button will open your Windows 10 "Setting > Apps > Default Apps" page. There should be a "Web Browser" option inside of this page, clicking on it will show a popup containing a list of browsers that you can set as your default browser, click on the Firefox icon and or browser and that should make Firefox your default browser.

You can refer to the screenshots provided down below. There is also a detailed guide on how to set Firefox as your default browser in this page, https://blog.mozilla.org/en/products/firefox/how-to-set-firefox-as-your-default-browser-on-windows/.

有幫助嗎?

more options

Thanks Lemonbear but I am on Linux openSuse and there is a tick in the box marked 'always check that Firefox is your default browser' and the box is greyed out so it can't be changed.

有幫助嗎?

more options

選擇的解決方法

If the "Always check if Firefox is the default browser" option is grayed out, you can forcefully and manually change this by entering "about:config" into your Firefox browser's search bar and changing the attribute value through that page.

1) Search up "about:config" in your Firefox search bar.

2) Click on "Accept the risk and continue."

3) Once you're in the page, type in "Shell" into the page's the search bar.

4) Look for "browser.shell.checkDefaultBrowser", the value for this attribute should be "true," double click on it to change it to "false." Exit the page and go about the to "Always check if Firefox is the default browser" option to see if it is still grayed out.

由 lemonbear2005 於 修改

有幫助嗎?

more options

Solved! Thank-you lemonbear2005

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題