搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

cannot search in address bar

  • 2 回覆
  • 1 有這個問題
  • 18 次檢視
  • 最近回覆由 eorylel

more options

Hello everyone,

I have been having an annoying problem in Fireforx (v.89.0) running on Fedora 33. In the past when I clicked in the address bar and typed in words to search for Firefox used Google and returned with search results. Now, when I try to do the same the search does not do anything, it just stays on the same page. This is in spite that the search setting is being set: "Use the address bar for search and navigation" and the default search engine is set to: "Google"

Any help with how can I get back the correct behaviour would be appreciated.

Thank you, Lel

所有回覆 (2)

more options

You can try this: 1. Set keyword.enabled to true Steps: a. Go to your address bar and type about:config b. Click accept the risk and continue c. Type keyword.enabled in the search bar d. Make sure keyword.enabled is true (by default should be true) Source: https://support.mozilla.org/en-US/questions/1154625

If the solution above is not working, you can try: 2. Clear cookies and saved data Steps: a. Go to firefox menu (3 bars icon at the top right corner of your browser) b. Click setting c. Click privacy & security from the left side bar d. Scroll down and look for cookies and site data e. Click clear data and proceed Note: You might need to restart firefox to make it work

You can also try: Remove or disable firefox add-ons that might affect the behaviour: Steps: a. Go to firefox menu (3 bars icon at the top right corner of your browser) b. Click add-ons and themes c. Under enabled, choose the add-on you want to disable, and click on the slide button of the add-on

Lastly, You can do anti-virus scan on your computer to make sure there is no virus hijacked your firefox browser. You also have to make sure your firefox browser is up-to-date, if not please do the update.

有幫助嗎?

more options

Hi ShenLoong,

I have tried all three of your suggestions, but nothing really helped. The keyword.enabled configuration was correctly set. After re-booting the computer or purging the cookies the firefox address bar search works, but then after a while it stops working completely. Disabling add-ons did not make a difference. The problem of not being able to use the address bar search functionality is not just an issue in newly opened tabs, but I checked and the search functionality does not work in the already opened tabs either. If I paste a known URL line that opens up OK, but searching is just not possible. Also, I noticed, that although my "home" is set to https://www.google.com when I press the home button that page does not load either. I have an up-to-date firefox version (firefox-89.0-1.fc33.x86_64), but I am planning to downgrade to firefox-88.0.1-1.fc33.x86_64 to see whether the same issues does occur there as well. I have only updated the version about two weeks ago and I am sure I had not had these problems before.

Thank you for the help, Lel

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題