搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Search engine

  • 1 回覆
  • 1 有這個問題
  • 5 次檢視
  • 最近回覆由 jscher2000

more options

I set my search preferences to have google as my default search engine. Today when I open FF the homescreen has the google icon in the search bar, but the results page comes from yahoo. How do i return it to google?

所有回覆 (1)

more options

Hi anna50, sorry to hear about the "hijacking." If Firefox shows it plans to send a search to Google (this usually shows in the bar below the search box) but you get a results page from a different site, this kind of in-flight redirection usually is caused by either an add-on or by external malware. You didn't share your extensions list while posting your question, so here's how to check for problem extensions on your Firefox:

Open the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, or privacy, or looks suspicious, or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?

If your Add-ons page is blank or is blocked, you can restart Firefox in its Safe Mode to do the above review:

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to bypass issues that can cause problems with pages.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Can you regain control of your searches?

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題