搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

how hide fields of "All Bookmarks (Library Window)" with userChrome?

  • 3 回覆
  • 1 有這個問題
  • 24 次檢視
  • 最近回覆由 cor-el

more options

the first image shows the standard appearance https://imgur.com/m6fecHE.png the second image shows how I want it to look, I want to keep only the field name of the bookmark and the field url/location https://imgur.com/nutwOWm the fields I want to hide are tags field but how i can?

附加的畫面擷圖

由 charles20091903 於 修改

被選擇的解決方法

This hides the bottom two rows but some space is not recovered (there's some extra blank space that isn't removed).

#editBookmarkPanelRows #editBMPanel_tagsRow,
#editBookmarkPanelRows #editBMPanel_tagsSelectorRow,
#editBookmarkPanelRows #editBMPanel_keywordRow {
  display: none !important;
}


To find other selectors, you can paste the following to the address bar and press Enter to load the source for the skeleton of the Library window:

view-source:chrome://browser/content/places/places.xhtml

But that won't give you the applicable CSS unfortunately, so it will take more work to chase down the source of the extra space.

P.S. Why Yandex Browser?

從原來的回覆中察看解決方案 👍 1

所有回覆 (3)

more options

The top line in the window (nomen endereco), right-click on it and select/deselect what you want.

more options

選擇的解決方法

This hides the bottom two rows but some space is not recovered (there's some extra blank space that isn't removed).

#editBookmarkPanelRows #editBMPanel_tagsRow,
#editBookmarkPanelRows #editBMPanel_tagsSelectorRow,
#editBookmarkPanelRows #editBMPanel_keywordRow {
  display: none !important;
}


To find other selectors, you can paste the following to the address bar and press Enter to load the source for the skeleton of the Library window:

view-source:chrome://browser/content/places/places.xhtml

But that won't give you the applicable CSS unfortunately, so it will take more work to chase down the source of the extra space.

P.S. Why Yandex Browser?

more options

The extra space seems to be that there is a height set to the #detailsPane container.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#editBookmarkPanelRows #editBMPanel_tagsRow,
#editBookmarkPanelRows #editBMPanel_tagsSelectorRow,
#editBookmarkPanelRows #editBMPanel_keywordRow {
  display: none !important;
}

#detailsPane {height:unset !important;}