搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

"Secure Connection Failed" Why am I getting this warning message so often when I try loading some websites sometimes?

more options

This is the warning message I am getting:

"Secure Connection Failed

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem.

Try again"

It has happened to me with YouTube, Google, Google Docs, and probably others that I can't remember right now. It doesn't happen all the time but it is happening often. I realized it yesterday. But I haven't been able to find anything to make it stop or solve it.

Right after it happens I just try refreshing/reloading the website and then it works normally and the warning disappears. I guess that is what makes it so weird. Why do I even get the warning in the first place?

Thank you so much in advance for any help you guys can provide me with.

This is the warning message I am getting: "Secure Connection Failed The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. Try again" It has happened to me with YouTube, Google, Google Docs, and probably others that I can't remember right now. It doesn't happen all the time but it is happening often. I realized it yesterday. But I haven't been able to find anything to make it stop or solve it. Right after it happens I just try refreshing/reloading the website and then it works normally and the warning disappears. I guess that is what makes it so weird. Why do I even get the warning in the first place? Thank you so much in advance for any help you guys can provide me with.
附加的畫面擷圖

所有回覆 (4)

more options

Hmm, puzzling.

The fact that it works so quickly on the second try could indicate that there's a filter in place that is a bit slow in verifying that the page is okay to visit. Some kind of security or parental control software maybe?

If you aren't aware of any security/parental control software running, try changing the proxy setting:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. Try "No proxy" and see whether that makes any difference.

Any progress so far?

more options

https://www.bing.com/search?q=pr_end_of_file_error

radi.stoyanov said Turns out the option DNS over HTTPS is what caused the problem.

jamesafuf123 said https://support.mozilla.org/en-US/questions/1264659#answer-1237475 my ISP was blocking sites like that

cor-el said This usually means that Firefox wasn't able to find a cipher suites to use to connect to this server and reached the end of the list. There can be two possibilities: one is that the server is outdated and doesn't support modern cipher suites, another might be that the server only supports a few cipher suites and Firefox doesn't support any of these.

You can check your browser and possibly compare this with the server setup.

more options

jscher2000 said

Hmm, puzzling. The fact that it works so quickly on the second try could indicate that there's a filter in place that is a bit slow in verifying that the page is okay to visit. Some kind of security or parental control software maybe? If you aren't aware of any security/parental control software running, try changing the proxy setting:
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it
In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click. The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. Try "No proxy" and see whether that makes any difference. Any progress so far?

Thank you so much. I will be looking out to see if it happens again. I just changed it to what you told me. Also, isn't it strange that it had never happened before and just started happening a couple days ago or so? What could possibly cause that?

more options

roxandara said

Also, isn't it strange that it had never happened before and just started happening a couple days ago or so? What could possibly cause that?

That's a good question. I guess it depends on what the filter does and how well it does it?