搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox causes entire screen to fade to black for 1 second

  • 6 回覆
  • 2 有這個問題
  • 52 次檢視
  • 最近回覆由 eubie9

more options

Hi, I'm trying to find out what's causing this behavior. My firefox sometimes, specifically when opening a second tab (doesn't happen on a third, fourth, fifth, etc. tab) and pressing F (like starting to type Facebook), makes my entire screen to fade to black for 1 second, and then comes back. If I do type facebook, it shows "acebook", ignoring the F entirely. It doesn't seem like a crash, it seems a lot like a functionality of sorts that's acting up, because it doesn't go black just like that, it fades. And it always takes the same amount of time with that fade.

What's worse, it doesn't always happen. If it happens once I can replicate it and keep doing it, but as I use the browser and it stops doing it, I can't do it again. Until, well, it does.

This is the weirdest thing. How does firefox control my entire screen like that? What's it doing? What instruction on my keyboard is F sending to firefox?

I haven't found anything like this happening to anyone online.

Any help please?

被選擇的解決方法

I figured it out. Youtube is usually my first tab. I occasionally access facebook (usually when I'm not doing anything else, which is why this happens in my second tab, also because if I try a third tab, the first tab is no longer youtube). Sometimes when I open a second tab, firefox doesn't leave youtube's focus right away. Youtube's keyboard shortcut to make a video go full screen is F. When it focuses the second tab, it ends the fade-to-black animation that going full screen causes, which is why the full screen doesn't stay.

TL;DR: Firefox doesn't leave youtube's tab focus fast enough, and pressing F makes it go fullscreen, hence the black screen fade.

從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options

Have you tried clearing up the browser cache? Or clearing up the ram memory? There are many tutorials online for cleaning up a browser... https://www.replicon.com/customer-zone2/kb-4928/ https://support.mozilla.org/en-US/questions/1223605#:~:text=To%20reduce%20the%20amount%20of,more%20RAM%20can%20utilize%20them.

more options

Taimur Ahmad said

Have you tried clearing up the browser cache? Or clearing up the ram memory? There are many tutorials online for cleaning up a browser... https://www.replicon.com/customer-zone2/kb-4928/ https://support.mozilla.org/en-US/questions/1223605#:~:text=To%20reduce%20the%20amount%20of,more%20RAM%20can%20utilize%20them.

I clear the cache every time I close the browser. But even if I did I've no idea how that would help as I didn't report a memory or slowness issue.

more options

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

cor-el said

You can try to disable hardware acceleration in Firefox. Close and restart Firefox after modifying the setting for changes to take effect. You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Are you advising this by witnessing this situation before? If so, can you clarify what it is? This doesn't really bother me too much. I'm just trying to figure out what functionality is causing it. I doubt hardware acceleration is sending an instruction to a specific keypress.

more options

選擇的解決方法

I figured it out. Youtube is usually my first tab. I occasionally access facebook (usually when I'm not doing anything else, which is why this happens in my second tab, also because if I try a third tab, the first tab is no longer youtube). Sometimes when I open a second tab, firefox doesn't leave youtube's focus right away. Youtube's keyboard shortcut to make a video go full screen is F. When it focuses the second tab, it ends the fade-to-black animation that going full screen causes, which is why the full screen doesn't stay.

TL;DR: Firefox doesn't leave youtube's tab focus fast enough, and pressing F makes it go fullscreen, hence the black screen fade.

more options

Found the cure. Set Chrome as default