搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox reports incorrect time

  • 4 回覆
  • 1 有這個問題
  • 10 次檢視
  • 最近回覆由 cor-el

more options

Firefox: latest (86.0 at the moment of posting this question) OS: Ubuntu 18.04.5

Problem: Firefox always reports time (to sites) in UTC (my correct timezone is UTC+7). That refers to site like everytimezone.com.

At the same time, Google Chrome on the same system reports correct time.

System clocks are synced to external time servers, time drift is negligible (if any).

How can one make Firefox report correct time (preferably without any extensions)?

所有回覆 (4)

more options

Probably you turned on privacy.resistFingerprinting -- that feature tells sites you are in UTC so they do not easily detect your real time zone. It's also why your Firefox reported that it is version 78.0 rather than 86.0.

有幫助嗎?

more options

@jscer2000 Indeed, this setting is enabled (set to true).

I searched through Mozilla Wiki, but no detailed description of immediate consequences of these settings are mentioned.

If I understand correctly, it's not possible to alter that setting on site by site basis?

有幫助嗎?

more options

I can't recall hearing of any way to create exceptions. It may be possible for an extension or userscript to read and adjust dates/times in pages after rendering. However, considering the diversity of website designs, a universal fixer probably is impossible.

有幫助嗎?

more options

See also:

Enabling "Resist Fingerprinting" is all or nothing and no workaround possible when enabled.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題