搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How to turn off the name of the search engine in a blue box in the address bar instead of the search shortcut as typed?

  • 2 回覆
  • 1 有這個問題
  • 4 次檢視
  • 最近回覆由 hysknrs

more options

When I typed any search shortcut (let's say "w" for Wikipedia) and then Space in the address bar, the bar would have just shown "w ".

After an update to 86, now typing "w " shows "Wikipedia" in a blue box instead of "w ". This is extremely irritating because I now can't just press Alt+D and enter a new search shortcut from scratch when I mistyped.

I have both browser.urlbar.update1 and browser.urlbar.update2 set to false.

所有回覆 (2)

more options

Instead of doing Alt-D you should just be able to press backspace, you only need to press it once unlike twice previously.

I understand this is a change of method and may take some getting used to, but hopefully it won't be too hard.

有幫助嗎?

more options

I'm specifically asking the way to turn it off. The new interface is extremely half-baked.

Since you've brought it up, the behavior of Backspace is also user-hostile. If you press W, Space, and then Backspace, it should bring it back to "w". But it removes the whole shortcut.

Ctrl+A also doesn't work as expected, which should select the entire query including the shortcut, not excluding it.

The most egregious thing is when you enter a shortcut at the beginning of an already-inserted query. Now the cursor is at the end of the entire query, not where it was at, i.e. the beginning of the query sans the shortcut.

This shouldn't have been rolled out so half-baked, let alone force everyone into it. "Get used to it" is an insulting thing to say when that new thing is clearly worse than what was already there.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題