搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Disable favicons on toolbars and bookmarks on Linux

more options

Hi guys, as I have already tried this method found here: https://support.mozilla.org/en-US/questions/9341987 and didn't work, now I'm stucked, and I don't want to change Firefox to another browser. Any tips on how can I completely disable favicons? The method works very well on Windows but on Linux, doesn't. I have also to mention that I am on Manjaro, XFCE (if it helps) Thanks, stay safe!

Hi guys, as I have already tried this method found here: https://support.mozilla.org/en-US/questions/9341987 and didn't work, now I'm stucked, and I don't want to change Firefox to another browser. Any tips on how can I completely disable favicons? The method works very well on Windows but on Linux, doesn't. I have also to mention that I am on Manjaro, XFCE (if it helps) Thanks, stay safe!

被選擇的解決方法

The CSS code I posted in that thread only hides the favicons on the Bookmarks Toolbar and should work on Linux as well. If you need to hide it in other places then you need to add rules with more selectors. On Linux plain text and possible hidden file extensions shouldn't be a problem

Does other code in the file work in your userChrome.css ? Did you make sure you created the file in the correct location ?

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Some Linux distributions do 'weird' things with their version from the repositories, so you can possibly test this with Firefox from the Mozilla server.

從原來的回覆中察看解決方案 👍 1

所有回覆 (4)

more options

That SUMO question link gives page not found, so I don't know what you tried. You can use code in userChrome.css to hide the favicon in some cases, but you might still see it somewhere where you can't use userChrome.css.

If CSS code works on Windows, then it would normally work on Linux as well.

Where in particular do you want to hide the favicons and where does it fail ?

more options

Marius Vaduva said

Hi guys, as I have already tried this method found here: https://support.mozilla.org/en-US/questions/9341987 and didn't work, now I'm stucked, and I don't want to change Firefox to another browser. Any tips on how can I completely disable favicons? The method works very well on Windows but on Linux, doesn't. I have also to mention that I am on Manjaro, XFCE (if it helps) Thanks, stay safe!

Sorry about that link. So the thing is, I used this one. https://support.mozilla.org/en-US/questions/1259492. However this doesn't work on Linux Any ideas on how to fix it? I created the chrome folder and the userChrome.css but still got no luck.

more options

選擇的解決方法

The CSS code I posted in that thread only hides the favicons on the Bookmarks Toolbar and should work on Linux as well. If you need to hide it in other places then you need to add rules with more selectors. On Linux plain text and possible hidden file extensions shouldn't be a problem

Does other code in the file work in your userChrome.css ? Did you make sure you created the file in the correct location ?

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Some Linux distributions do 'weird' things with their version from the repositories, so you can possibly test this with Firefox from the Mozilla server.

more options

Hello there.

As I said before, my profile folder is correct, I have created the "chrome" folder, as well as the userChrome.css file but nothing happened. I don't understand how in Windows is working but in Linux doesn't. I'm glad you did your best to help me, but the problem hasn't been solved yet. I will try adding a theme and see if the userChrome.css file will be taken and theme my Firefox. All in all, I am stuck with this favicons on tabs which I don't really want them.

Thank you, stay safe.

P.S: After a quick search I found a very easy and simple solution to this problem. I have followed this tutorial on https://www.howtogeek.com/howto/internet/firefox/quick-tip-disable-favicons-in-firefox/ this page. Problem solved.

由 Marius Vaduva 於 修改