搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Bookmarks saving above folders instead of below since FF update #85

  • 8 回覆
  • 1 有這個問題
  • 23 次檢視
  • 最近回覆由 jscher2000

more options

Since the recent update to FireFox (#85), bookmarks now save at the top of the Bookmarks list instead of underneath at the bottom of the list. What has changed? How to change it back? Also, I would like to eliminate the "Other Bookmarks" and "Mobile Bookmarks" folders but cannot. I never use these How to do I get rid of these? (Windows10 desktop)

被選擇的解決方法

jscher2000...

I followed these instructions:

Accessing the Profile Manager http://kb.mozillazine.org/Profile_Manager#Accessing_the_Profile_Manager

Recent versions of Thunderbird and Firefox have a about:profiles link in Help -> Troubleshooting Information. Clicking on that link launches an enhanced version of the profile manager. That is the easiest way to launch the profile manager. If you do that you don't need to read the rest of this KB article.

At: Troubleshooting Information

Try clearing the startup cache That did not resolve issue. Bookmarks html still loaded with bookmarks outside of folders.

Try Safe Mode This worked. Bookmarks loaded properly. Added a bookmark correctly into Bookmarks Menu.

Disabled these Addons:

Default Bookmark Folder : this was enabled https://addons.mozilla.org/en-US/firefox/addon/default-bookmark-folder/

Bookmarks Organizer : this was disabled https://addons.mozilla.org/en-US/firefox/addon/bookmarks-organizer/

I removed both addons. Informed "Default Bookmark Folder" addon that it does not currently work properly.

Thank you, jscher2000, for your concern and assistance. :)

從原來的回覆中察看解決方案 👍 0

所有回覆 (8)

more options

Hi Dave, I saw another report of this earlier in the day but I don't experience it myself. Which list are you using for reference?

Other Bookmarks is a built-in category for all Firefox installations, and can't be removed. Sorry. Maybe it can be hidden from some views.

Mobile Bookmarks appears if you are using Firefox Sync. I assumed it only appeared if you joined a mobile device to the account, but I haven't looked into it closely. Since this is the only way I know to "back up" mobile bookmarks, and an easy way to share links between a mobile device and your desktop Firefox, it can be pretty useful. But if you don't sync a mobile device, hmm, maybe it can be hidden from some views.

有幫助嗎?

more options

All my bookmarks are in "Bookmarks Menu" except for some in "Bookmarks Toolbar". There are several folders in the "Bookmarks Menu". When I bookmark a page, it puts the bookmark above the folders instead of below the folders as it has for years.

And another issue: I decided that I would export all my bookmarks to html file, and then delete them all from the "Bookmarks Menu" to see if that would solve the problem. Then I closed Firefox as usual and cleaned all cookies, history, etc. with an app on my desktop as I have done for years. I launched FireFox, opened the "Show All Bookmarks", opened "Bookmarks Menu" and imported the html file I just exported. FireFox loaded all the bookmarks - but not in their respective folders - it loaded them outside the folders and all mixed up. The folders are empty.

So what now?!!? Everything was fine until Firefox updated to #85.

有幫助嗎?

more options

Try restoring the last automatic backup. It probably will be missing the past 24 hours. This article has the steps:

Restore bookmarks from backup or move them to another computer

After that, you can consult your export file to re-add the recent bookmarks. Obviously this will be easiest if they were saved near one another. Open the export file in a tab in Firefox, find the link for the missing bookmark, right-click it, and Bookmark This Link. (If needed, I can write some script to flag the latest items in the export file.)

有幫助嗎?

more options

Update...

So I thought perhaps the html file might be corrupted so I deleted the current bookmarks and imported the html file I exported yesterday - before Firefox updated. No success - the same thing occured - all the bookmarks are outside of their respective folders.

I am now extremely frustrated as I am doing research for a client and bookmarking pages as reference. Now my work is at a standstill!!!

有幫助嗎?

more options

Dave, try the Restore I mentioned.

You also can check the health of or repair the Places database using the "Verify Integrity" tool. That's here:

Open Firefox's Troubleshooting Information page using any of these methods:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Near the bottom, there is a section titled Places Database -- that's the file which stores history and bookmarks. Click the button labeled Verify Integrity. There may be a 10-15 second delay before results appear.

If all is well, the report that appears below the button should start with:

> Task: checkIntegrity
+ The places.sqlite database is sane
+ The favicons.sqlite database is sane

If the report seems to indicate problems, you can select and copy it, and paste it into a reply for review and comment.

有幫助嗎?

more options

選擇的解決方法

jscher2000...

I followed these instructions:

Accessing the Profile Manager http://kb.mozillazine.org/Profile_Manager#Accessing_the_Profile_Manager

Recent versions of Thunderbird and Firefox have a about:profiles link in Help -> Troubleshooting Information. Clicking on that link launches an enhanced version of the profile manager. That is the easiest way to launch the profile manager. If you do that you don't need to read the rest of this KB article.

At: Troubleshooting Information

Try clearing the startup cache That did not resolve issue. Bookmarks html still loaded with bookmarks outside of folders.

Try Safe Mode This worked. Bookmarks loaded properly. Added a bookmark correctly into Bookmarks Menu.

Disabled these Addons:

Default Bookmark Folder : this was enabled https://addons.mozilla.org/en-US/firefox/addon/default-bookmark-folder/

Bookmarks Organizer : this was disabled https://addons.mozilla.org/en-US/firefox/addon/bookmarks-organizer/

I removed both addons. Informed "Default Bookmark Folder" addon that it does not currently work properly.

Thank you, jscher2000, for your concern and assistance. :)

有幫助嗎?

more options

Hi Dave, thank you for the update. Your last reply had a link to a third party site so it's in the moderation queue, but I appreciate the detective work and it should become visible in a few hours.

有幫助嗎?

more options

Hi Dave, adding bookmarks at the top of the menu was a bug in version 3.0.0 of the Default Bookmark Folder extension, and the failed import might have been a related issue. The extension is still being adapted to the changes in Firefox 85, so you might check in on it again next week if you can't live with the new "save in the same folder as the last bookmark" behavior in Firefox 85.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題