搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Disable auto restoring session after crash

  • 3 回覆
  • 1 有這個問題
  • 14 次檢視
  • 最近回覆由 cor-el

more options

I like to disable the automatic restore of sessions in all circumstances. I'd prefer to retain my history though.

Using firefox 84.0.2 on Ubuntu 20.04 Whenever I logout/login or restart the OS, FF restores my last session without asking. It's ok when I close FF first (FF starts a new session) but every other app shuts and resumes gracefully.

There are a lot of similar questions suggesting various settings...

browser.sessionhistory.max_entries =0 browser.sessionhistory.max_total_viewers=0 browser.sessionstore.max_resumed_crashes=0 browser.sessionstore.max_tabs_undo=0 browser.sessionstore.max_windows_undo=0 browser.sessionstore.resume_from_crash=false

"Restore previous session" is unset.

None of this solves the problem.

Comments on other post suggest that linux shut down causes FF to crash. Seems that you cannot disable the restore session after crash and I get no "Do you want to...." screen.

Is there no way to tell FF not to restore crashed sessions?

所有回覆 (3)

more options

Setting browser.sessionstore.max_resumed_crashes = 0 should prevent Firefox from automatically restoring the session. You will still get the about:sessionrestore page where you can decide what tabs you want to restore or whether you want to start a new session.

Doesn't that work for you or isn't that enough ?

Do you experience a lot of crashes that you want to disable restoring tabs ?


If you have submitted crash reports, please post the IDs of one or more recent crash reports that start with "bp-".

  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

You can find the report ID of recent crash reports on the "Help -> Troubleshooting Information" (about:support) page.

  • click the "All Crash Reports" button on this page to open the about:crashes page and see all crash reports.

Alternatively you can open about:crashes via the location/address bar.

See also:

有幫助嗎?

more options

Thanks for the reply. browser.sessionstore.max_resumed_crashes is already set to 0

I never get the about:sessionrestore page which is strange...

I have also tried a different profile, deleting all session files, the session history folder from the profile and ~/.cache/mozilla in case of corruption.

Also tried purging and reinstalling Firefox. No change.

Guess I'll have to live with it :)

有幫助嗎?

more options

Are you sure that Firefox is crashing (i.e. do you get the crash reporter) ?

Note that Firefox from the Ubuntu repositories may behave differently than Firefox from the Mozilla server.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題