搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

page and tab refresh when loading

  • 3 回覆
  • 1 有這個問題
  • 9 次檢視
  • 最近回覆由 jscher2000

more options

Firefox 84.0.2 (64-bit) in Ubuntu 18.04

I often load pages with many tabs. These tabs are NOT refreshed when loading, so data may be days old. It's easy to think data is fresh, since Firefox just started, but WRONG !

This wastes lots of time, both in errors and manually restarting each of many tabs.

I need to find how to set Firefox to NOT use old data when it starts. I don't need to refresh every few minutes or hours,, JUST when starting.

HOW do I accomplish this ?!?

Thanks!

被選擇的解決方法

So if I understand the problem:

  • you have Firefox set to restore your previous session tabs at startup
  • when it activate a tab, Firefox shows its content from the last session
  • Firefox loads the fresh content if you reload the tab manually
  • you prefer that Firefox always get fresh content for restored tabs

I suggest trying this: set Firefox to clear the web cache at shutdown.

Note: do not clear browsing history, or Firefox won't be able to restore any tabs. Here's how you set that:

Open the Preferences page:

  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the tiny search box at the top of the page, type cache and Firefox should filter the page. Then:

  • In the History section, set the selector to "Firefox will: Use custom settings for history"
  • Check the box for "Clear history when Firefox closes"
  • Click the Settings button to the right of the box and UNCHECK everything except Cache -- you only want to clear Cache

At the next startup, when you activate a restored tab, Firefox should pull the content from the web.

從原來的回覆中察看解決方案 👍 0

所有回覆 (3)

more options

The only tabs that auto refresh when I open the browser are the pinned tabs and the the tab that is showing when the browser opens. The other tabs will refresh when they are clicked on. Do you not have the same behavior? Maybe try pinning the tabs you want to refresh when you open the browser.

有幫助嗎?

more options

Good information, but not a solution.

My best answer would be to have EVERY tab refresh as it is opened during startup, or better yet, when it is selected for viewing.

Is there a way to do this in about:config?

Thanks!

有幫助嗎?

more options

選擇的解決方法

So if I understand the problem:

  • you have Firefox set to restore your previous session tabs at startup
  • when it activate a tab, Firefox shows its content from the last session
  • Firefox loads the fresh content if you reload the tab manually
  • you prefer that Firefox always get fresh content for restored tabs

I suggest trying this: set Firefox to clear the web cache at shutdown.

Note: do not clear browsing history, or Firefox won't be able to restore any tabs. Here's how you set that:

Open the Preferences page:

  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the tiny search box at the top of the page, type cache and Firefox should filter the page. Then:

  • In the History section, set the selector to "Firefox will: Use custom settings for history"
  • Check the box for "Clear history when Firefox closes"
  • Click the Settings button to the right of the box and UNCHECK everything except Cache -- you only want to clear Cache

At the next startup, when you activate a restored tab, Firefox should pull the content from the web.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題