搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox Nightly Video Playback on Fedora 33

  • 15 回覆
  • 1 有這個問題
  • 11 次檢視
  • 最近回覆由 Bryan Moore

more options

I've installed Nightly the same way I have for years on my latest Fedora 33 install—i.e., download tarball, extract into /opt, set appropriate chmod and chown, make .desktop file, etc.—but certain videos certain videos on certain sites refuse to play. A Fedora discussion discussion led me to think it's how Fedora 33 may sandbox apps; I haven't yet had any hits on solutions in the Fedora groups, so I thought I'd ask here, since I can't be the only one with this issue.

Any help would be greatly appreciated!

被選擇的解決方法

Make sure you have the latest FFmpeg and libavcodec packages installed.

You can also check the Web Console for possible messages.

從原來的回覆中察看解決方案 👍 0

所有回覆 (15)

more options

It works for me. Have you tried it in safe mode. I just downloaded Nightly, extracted it, made a shortcut on my desktop. Do you have any issues with YouTube? KDE or Gnome?

Operating System: openSUSE Tumbleweed 20210101 KDE Plasma Version: 5.20.4 KDE Frameworks Version: 5.77.0 Qt Version: 5.15.2 Kernel Version: 5.10.3-1-default OS Type: 64-bit Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

由 jonzn4SUSE 於 修改

有幫助嗎?

more options

Thanks for checking in, @jonzn4SUSE...

I have tried it in safe mode, without success; YouTube plays just fine, as do several other sites. No love for TED and a few others.

I really wonder if this is due to some of Fedora's sandboxing features; e.g., openH264 is installed as a flatpak, although that shouldn't matter as Nightly seems to ship with it's own openH264.

由 Bryan Moore 於 修改

有幫助嗎?

more options

KDE or Gnome. Does it work in the distro current version of Firefox?

由 jonzn4SUSE 於 修改

有幫助嗎?

more options

Sorry, I meant to include it was GNOME.

The distro version (84.0.1-2.fc33) works fine.

有幫助嗎?

more options

Interesting... Maybe try downloading it again and just extract and run it. Can you also post a screenshot of the issue?

有幫助嗎?

more options

Did that a couple of times...

有幫助嗎?

more options

What if you download it and try to play it?

有幫助嗎?

more options

Plays fine in Videos when downloaded.

由 Bryan Moore 於 修改

有幫助嗎?

more options

.....

由 jonzn4SUSE 於 修改

有幫助嗎?

more options

Yeah, looking like more of a Gnome / Ubuntu issue. Just for kicks, if you feel like testing... switch to KDE and see what happens.

有幫助嗎?

more options

It can't be an Ubuntu issue, since I'm on Fedora, and I'm not sure being on GNOME would make any difference; however, I'm becoming more and more convinced it's a quirk of Fedora's new sandboxing.

Thanks, anyway, @jonzn4SUSE...

由 Bryan Moore 於 修改

有幫助嗎?

more options

LMAO.... Ubuntu on the brainu.  ;-))

有幫助嗎?

more options

No worries... It's extra-comical to me because I started my Linux journey with Ubuntu (back in the good ol' Warty days) and used it up until about two or three years ago. :-)

有幫助嗎?

more options

選擇的解決方法

Make sure you have the latest FFmpeg and libavcodec packages installed.

You can also check the Web Console for possible messages.

有幫助嗎?

more options

Didn't even think to check libavcodec, @cor-el, and that was it; installing "GStreamer Multimedia Codecs - libav" fixed things.

Thanks a ton!

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題