搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How to prevent every link I click to open in a new tab

  • 6 回覆
  • 1 有這個問題
  • 46 次檢視
  • 最近回覆由 Dave Z

more options

I just came back to Firefox after about 2 months, as Microsoft crushed my OS with their fall feature update. I could not get many items running, and just had to start from scratch.

That being said, I surely do not recall that every time I clicked a link, it would open in a new tab. I mean, every single time. Who ever thought that was a good idea.

Anyone have a clue as to what's happening here? I usually only want a new tab to open when either I choose it as a right-click option, or when builders have invested it specifically in their code, as they know it will navigate away from their site, etc...

I would be most thankful to get this baby back running like normal. Your help is appreciated!

Btw, fresh windows 10 install. The only extensions I have running are adblock, lastpass, blur, downloadthemall and new tab homepage (which just let's me determine the page address.)

被選擇的解決方法

Links that specify a target window open a new window that you can divert to a new tab via "Options/Preferences".

For other cases there prefs on the about:config page to control this behavior.

Normal Links:

  • browser.link.open_newwindow
    1:current tab; 2:new window; 3:new tab;

JavaScript Links:

  • browser.link.open_newwindow.restriction
    0:divert always; 1:divert never; 2:divert no features

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

從原來的回覆中察看解決方案 👍 1

所有回覆 (6)

more options

Type about:preferences#general<enter> in the address bar. Look under Tabs.

有幫助嗎?

more options

Hey Fred,

Thanks so much for the guidance. Unfortunately, I have been to this area, and the only options they offer are to open links in new window or when opening them in new tab, switch directly to them. The other two items under Tabs do not alter or adjust the process.

I feel like I'm a bit like Alice in the rabbit hole.

Seriously, I want to click a link, and then that same window/tab should simply navigate to that new page, like browsers have been doing for a long time. The idea that every single time I click a link, a new tab opens up is madness. I click through a website, and I suddenly have 8 tabs opened, all to the same page with slightly different displays.

Crazier still, in that new tab, I can navigate backwards to the page I left, but that page is actually in the previous tab to the left. Forward/backward navigation is like a useless redundancy.

Really hoping someone knows what is happening here, as it seems like there is probably some switch somewhere I am missing...

Thanks again!

有幫助嗎?

more options

選擇的解決方法

Links that specify a target window open a new window that you can divert to a new tab via "Options/Preferences".

For other cases there prefs on the about:config page to control this behavior.

Normal Links:

  • browser.link.open_newwindow
    1:current tab; 2:new window; 3:new tab;

JavaScript Links:

  • browser.link.open_newwindow.restriction
    0:divert always; 1:divert never; 2:divert no features

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

有幫助嗎?

more options

Firefox still won't send a link to a new window or tab on a simple left-click unless the page is coded to do that (or you are browsing in a pinned tab and opening a link to a different site). Same as always.

This part --

Dave Z said

I click through a website, and I suddenly have 8 tabs opened, all to the same page with slightly different displays. Crazier still, in that new tab, I can navigate backwards to the page I left, but that page is actually in the previous tab to the left. Forward/backward navigation is like a useless redundancy.

--- is very strange because there's nothing a site could put in its code to duplicate the current tab with its "Back" history. I also can't think of any modifier keys that you could hold (intentionally or accidentally) to cause the tab to duplicate before navigating.

有幫助嗎?

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

有幫助嗎?

more options

Hey All,

Thanks so very much for your time and help!

What a strange thing to have to do, and even odder that it isn't a simple choice in the options section for tabs and reading, etc...

Still and all, switched the setting under About:Config to 1 (open in same tab), and all is rosy again.

I don't recall running into this in the past, not with Firefox at least, but then again, I was running that rig and setup for prolly over two years, so its possible.

Anyway, thanks again for all of your suggestions!

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題