搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Browser window prompt to "Open Network Login Page"

  • 1 回覆
  • 1 有這個問題
  • 2 次檢視
  • 最近回覆由 jscher2000

more options

When I open a tab, I get this notice: "Open Network Login Page": "You must log in to this network before you can access the internet."

When I close that tab, I can proceede as normally.

If I click on that button where it says "Open Network Login Page," I get another screen where that button is gone, and it says "You must log in to this network before you can access the internet."

Here is the URL: https://detectprotal.firefox.com/success.txt

Both of these pages has a question mark in a circle, but this is not clickable.

I am enclosing screenshots.

This is Firefox version 82.0.3 I use a Mac Book, version 10.14.6

Thanks!

附加的畫面擷圖

所有回覆 (1)

more options

Sorry, this was due to a temporary server issue on Mozilla's side. You can disable the captive portal feature, or edit a file on disk. I'll describe both options.

Captive Portal Feature

Firefox has a feature called captive portal detection which attempts to reach a Mozilla site in the background and if it doesn't work, it may present a message like that. This is intended to help with public wireless hotspots where you might otherwise get secure connection errors on the authentication page.

You can turn off the feature and see whether it makes any difference. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste portal and pause while the list is filtered

(3) Double-click the network.captive-portal-service.enabled preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

The HSTS Flags File

The portal detect page is not supposed to use HTTPS, but due to the server issue, a flag would be stored by Firefox requiring HTTPS. This is stored in a text file in your profile. You either can delete one line from this file or delete the entire file (either way, while Firefox is not running).

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Quit, either:

  • "3-bar" menu button > Quit
  • (menu bar) Firefox > Quit

Pause while Firefox finishes its cleanup, then find the file named SiteSecurityServiceState.txt

Editing Option

I don't know Mac very well, but you would need to use a program that doesn't change the format from plain text to rich text or inject any word processing or formatting codes. The line you're looking for would have detectportal.firefox.com on it.

EDIT: it might just have firefox.com instead of the full domain suggested earlier.

Removal Option

If you delete the file, Firefox will start rebuilding it as it receives HSTS instructions from websites you visit.

由 jscher2000 於 修改

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題