搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

"Search with Amazon.com" pinned on seletion of URL bar

  • 2 回覆
  • 1 有這個問題
  • 11 次檢視
  • 最近回覆由 spartanhooah

more options

When I hit cmd+l to select the URL bar, the first entry in the suggestion list is "Search with Amazon.com" with a pin icon to the left of it. I've searched all through the preferences and even about:config and any reference to Amazon is disabled. How can I get this to go away?

被選擇的解決方法

When you first click in (or focus) the address bar, by default, Firefox shows 8-10 Top Sites from your Firefox Home / new tab page. The ones with the tiny gray pin are pinned to the Top Sites section.

You should be able to remove pinned sites from the Firefox Home / new tab page by hovering the site until a menu button appears (...), clicking that button, and then choosing Unpin or Dismiss. More info: Customize the New Tab page.

If the search engine shortcuts -- the ones that put @amazon or @google in the address bar when you click them -- are stubborn, there is another way to remove those:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste searchshort and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

從原來的回覆中察看解決方案 👍 0

所有回覆 (2)

more options

選擇的解決方法

When you first click in (or focus) the address bar, by default, Firefox shows 8-10 Top Sites from your Firefox Home / new tab page. The ones with the tiny gray pin are pinned to the Top Sites section.

You should be able to remove pinned sites from the Firefox Home / new tab page by hovering the site until a menu button appears (...), clicking that button, and then choosing Unpin or Dismiss. More info: Customize the New Tab page.

If the search engine shortcuts -- the ones that put @amazon or @google in the address bar when you click them -- are stubborn, there is another way to remove those:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste searchshort and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

有幫助嗎?

more options

Thanks. The first way did it. I have a blank new tab, and didn't know what needed to be enabled there to see those options.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題