搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

My logins are being saved directly against my permission/choices

  • 3 回覆
  • 1 有這個問題
  • 26 次檢視
  • 最近回覆由 FredMcD

more options

Hello. I think I asked this question a while ago but I lost my access during a disk migration. I am alarmed and disappointed that when I log in to sites, Firefox shows me prior login information to choose from. I have attached a screen shot from protonmail with my actual logins obscured, but note how it also showed me a gmail account? This implies some general saving feature.

I have repeatedly scoured every setting that firefox has and have absolutely definitely unchecked all boxes to do with asking to save passwords, and saving them. I have also carefully selected that cookies and data be deleted on exit and I have no exceptions to this.

This is the antithesis of the security approach that firefox led me to think it takes! Could someone tell me what is going on? Something is behind the scenes scraping information that firefox then references, by the looks of it.

Many thanks for your suggestions, and sorry if this question has already been answered: I could not find anything that directly addressed this question (including my potential earlier question) using the search function.

附加的畫面擷圖

被選擇的解決方法

The screenshot is too small to make out anything.


Have you checked the Password Manager?


That could be the form filler built into Firefox. Click in the field, enter a character or two and STOP ! Using the arrow keys, highlight an unwanted entry. Then press Shift > Delete Repeat as needed.

Do any of these links help you? https://support.mozilla.org/en-US/kb/control-whether-firefox-automatically-fills-forms

https://support.mozilla.org/en-US/search?w=1&q=autofill

從原來的回覆中察看解決方案 👍 1

所有回覆 (3)

more options

選擇的解決方法

The screenshot is too small to make out anything.


Have you checked the Password Manager?


That could be the form filler built into Firefox. Click in the field, enter a character or two and STOP ! Using the arrow keys, highlight an unwanted entry. Then press Shift > Delete Repeat as needed.

Do any of these links help you? https://support.mozilla.org/en-US/kb/control-whether-firefox-automatically-fills-forms

https://support.mozilla.org/en-US/search?w=1&q=autofill

有幫助嗎?

more options

Hi Fred, many thanks, and sorry about the small screen shot. I THINK the first link solved the problem. As the form box was a second level option, I assumed that it was not active when the first level option above was not checked - so some pretty misleading design by Firefox. I tried out the website again and the options were no longer there - solved! BUT in order to answer this question I had to log in to firefox and two things happened. (a)firefox prefilled my email, which I thought was now a solved problem and (b) I was horrified to discover that Firefox was cheerfully attaching sensitive information from my email to my display name for this question, in the form of a user name in brackets. Firefox, please - a display name is the name that is displayed! NOTHING else should be displayed. Don't have a user name if it is going to be displayed. That's what the display name is for! And definitely DO NOT auto fill the user name with information from my email. Every single other website I have ever used has kept my email private when they use a display name. It's just Firefox that autocreated an additional privacy-damaging user name and left me to find out about it. I am left with the same impression that Firefox is trying to trick us into revealing information - which is not what I thought Firefox was about. If you can get this message through to the developers it would be appreciated.

有幫助嗎?

more options

Glad to help. Safe Surfing.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題