搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

[Mysolved] How to disable all shortcuts in FF?

  • 6 回覆
  • 1 有這個問題
  • 4 次檢視
  • 最近回覆由 rey0n

more options

As there is no way to customize FF shortcuts, How to Disable them all together? In any way: editing settings, browser internal files, whatever. No, it's not about addon shortcuts. Yes, i already checked smt like a hundred topics/adviced addons web-search could provide, and none works.

由 rey0n 於 修改

被選擇的解決方法

so, as there is no help and Firefox can't provide simpliest customization ability, here's a hack-solution i found for those like me searching for one:

0/ Everything below is done with NO Firefox runing, close it beforehand

1/ App folder Firefox\browser\omni.ja -open this file with any archiver(basically it's a zip file with changed extension). Inside of omni.ja look for \chrome\browser\content\browser\browser.xhtml =extract it, this file contains keyboard shortcuts(and many interesting stuff).

2/ If you want to change some shortkeys, search for for proper blocks(example bellow) OR comment everything inside <keyset id="mainKeyset">..</keyset> =this should disable ALL shortkeys Example, changing shortkey for "Quit Firefox"

   <key id="key_quitApplication" data-l10n-id="quit-app-shortcut"
        modifiers="accel,shift"
        command="cmd_quitApplication"
        reserved="true"/>

=original block found in browser.xhtml

   <key id="key_quitApplication"
        key="w"
        modifiers="accel,shift,alt"
        command="cmd_quitApplication"
        reserved="true"/>

=edited block that makes usual Ctrl+Shift+Q to become Ctrl+Shift+Alt+W =(compare to understand what makes difference)

3/ Drop edited [browser.xhtml] into its place in [omni.ja] with NO archivation

4/ Profile folder of Firefox - Delete \startupCache folder for edits to take effect(folder will be recreated with browser start)

Hope this will help to smb stubborn and searching for solution like me.)

從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options

The question is a little ambiguous, but from what I understand you are referring to keyboard shortcuts. If that's the case : 1. Open a new tab in FF and type "about:config" and ENTER. 2. You might get a screen asking you to proceed with caution (you should !) and click on proceed. 3. In the search bar, paste "permissions.default.shortcuts". 4. Double click on the field and enter 2 (to completely block it) and click on the tick symbol.

Hopefully, that should solve it. If not, please reply with a better explantion of the problem.

有幫助嗎?

more options

deleted.

由 rey0n 於 修改

有幫助嗎?

more options

2Bor~2B said

4. Double click on the field and enter 2 (to completely block it) and click on the tick symbol.

tried before asking here, no effect, keyboard shortcuts still work. the problem is simple - as FF doesn't allow customization of its keyboard shortcuts, i want to turn them off completely.

有幫助嗎?

more options

選擇的解決方法

so, as there is no help and Firefox can't provide simpliest customization ability, here's a hack-solution i found for those like me searching for one:

0/ Everything below is done with NO Firefox runing, close it beforehand

1/ App folder Firefox\browser\omni.ja -open this file with any archiver(basically it's a zip file with changed extension). Inside of omni.ja look for \chrome\browser\content\browser\browser.xhtml =extract it, this file contains keyboard shortcuts(and many interesting stuff).

2/ If you want to change some shortkeys, search for for proper blocks(example bellow) OR comment everything inside <keyset id="mainKeyset">..</keyset> =this should disable ALL shortkeys Example, changing shortkey for "Quit Firefox"

   <key id="key_quitApplication" data-l10n-id="quit-app-shortcut"
        modifiers="accel,shift"
        command="cmd_quitApplication"
        reserved="true"/>

=original block found in browser.xhtml

   <key id="key_quitApplication"
        key="w"
        modifiers="accel,shift,alt"
        command="cmd_quitApplication"
        reserved="true"/>

=edited block that makes usual Ctrl+Shift+Q to become Ctrl+Shift+Alt+W =(compare to understand what makes difference)

3/ Drop edited [browser.xhtml] into its place in [omni.ja] with NO archivation

4/ Profile folder of Firefox - Delete \startupCache folder for edits to take effect(folder will be recreated with browser start)

Hope this will help to smb stubborn and searching for solution like me.)

有幫助嗎?

more options

As far a I know then the two omni.ja archives are signed in current Firefox releases (they have a META-INF folder) and that makes it impossible to tamper with these archive files.

有幫助嗎?

more options

cor-el said

As far a I know then the two omni.ja archives are signed in current Firefox releases (they have a META-INF folder) and that makes it impossible to tamper with these archive files.
can't say for sure how, but it works for me. maybe 'cause i have browser.launcherProcess.enabled= false

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題