搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Open IoT web site in Firefox

more options

Hello,

I have a webserver runs on sp8266. Address is http://esptimer/ but when I try to open it in Firefox 80.0 on Linux the address changes to www.esptimer.com and wont work. I tried http://esptimer/ in Google Chrome and it works. Is there is possibility to open IoT local webserver in Firefox?

(changing of keyword.enabled does not work)

Thank you.

Hello, I have a webserver runs on sp8266. Address is http://esptimer/ but when I try to open it in Firefox 80.0 on Linux the address changes to www.esptimer.com and wont work. I tried http://esptimer/ in Google Chrome and it works. Is there is possibility to open IoT local webserver in Firefox? (changing of keyword.enabled does not work) Thank you.

所有回覆 (3)

more options

http://esptimer/ is not a proper web address. All addresses I have seen have <dot> something at the end.

and when I try http://www.esptimer.com/ I get:

Server not found Firefox can’t find the server at www.esptimer.com

more options

^: note that this is about a local server and not internet.


You can look at these prefs on the about:config page.

See also:

由 cor-el 於 修改

more options

Is it possible your Firefox is using DNS over HTTPS in strict mode? If so, you may need to create exceptions for your local host names. You could take a look here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste trr and pause while the list is filtered

If the network.trr.mode preference is bolded and has a value of 2 or 3 then DoH is enabled. The difference is:

  • Mode 2: if your trusted resolver doesn't know the address, Firefox should check local DNS
  • Mode 3: if your trusted resolver doesn't know the address, Firefox should assume it doesn't exist

If you are set to Mode 3, you could try Mode 2 instead.

Alternately, or to save a lookup, you could try this:

(3) Double-click the network.trr.excluded-domains preference to display an editing field:

  • If it's blank, type or paste esptimer
  • If you already have some host names listed, ad a comma at the end and then type or paste esptimer

Either press Enter or click the blue check mark button to save the change.