搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Leave page warning box

  • 6 回覆
  • 1 有這個問題
  • 231 次檢視
  • 最近回覆由 dafix1972

more options

The last 2 days im getting the do you want to leave this page warning box on every single page. When clicking a link/refreshing or closing the browser.

I dont have to have entered any info in a dialog box or do anything except load a page, and it just keeps coming up. Now its started affecting making a payment online as i have to choose leave this page for every step through a payment process which has messed up some payments.

Why is it suddenly popping up on untouched pages all the time and how the hell can i get rid of it?

Ive not changed any settings recently. And i dont want to start adding scripts to stop it.

The last 2 days im getting the do you want to leave this page warning box on every single page. When clicking a link/refreshing or closing the browser. I dont have to have entered any info in a dialog box or do anything except load a page, and it just keeps coming up. Now its started affecting making a payment online as i have to choose leave this page for every step through a payment process which has messed up some payments. Why is it suddenly popping up on untouched pages all the time and how the hell can i get rid of it? Ive not changed any settings recently. And i dont want to start adding scripts to stop it.

被選擇的解決方法

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
從原來的回覆中察看解決方案 👍 1

所有回覆 (6)

more options

Hi dafix1972, that's unusual, Firefox can't do that on its own, as far as I know.

You do have quite a few add-ons on the list you shared. In case one of those is causing the issue, can you check their Options or try disabling all the ones you can live without for 10 minutes to see whether that is related to this problem? Here's how:

You can view, disable, and often configure and remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage.

First, if there is anything suspicious or that you just do not remember installing or why, disable or remove it.

Next, some extension offer their settings panels through this page. Click the extension title to show the Details panel, and see whether Options/Preference/Settings are available there. If not, the extension might offer that through a toolbar button, right-click context menu, etc.

Finally, if problems continue, try disabling everything you can live without for 10 minutes to see whether it changes anything. You can bring back the more useful ones gradually.

Any progress so far?

more options

I already went through my addons and extensions thinking some might have gone rouge with settings but none of them disabled made any difference.

more options

And you get the dialog shown in the attached? This only appears if the page has a script -- either its own script or a script injected by an add-on or maybe some kind of external software -- that hooks into the onbeforeunload event (i.e., when closing or leaving a page). If the pages do not normally do it, and none of your extensions are doing it, are you aware of using any external filters ("man in the middle") that may be modifying pages loaded into Firefox?

more options

Yeah thats the box. I have no idea if theres any filters causing it. all i know is i only used to get it when i had entered dialog into a box or had clicked a radio button before closing a page/browser.

I think im gonna have to do a trawl through everything i can find via google and communities :)

more options

選擇的解決方法

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

hi thanks for the help although i have no idea what was causing it but i used safe mode and switched the hardware acceleration and it didn't happen during safe mode. went back to normal mode and switched hardware acceleration back and its not happened since. :) Obviously something wasn't happy beforehand.

Would safe mode have reset something? Thanks  :)