搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why some switches i change from "about:config" at every firefox update return to default state?

  • 13 回覆
  • 1 有這個問題
  • 17 次檢視
  • 最近回覆由 AliceWyman

more options

Hi.

Why the switch "browser.launcherProcess.enabled" even i have change it to FALSE everytime firefox update it return to it's default state that is true?????

Is there any way to make this swich "browser.launcherProcess.enabled" ALWAYS STAY AT FALSE STATE????

And if i can do that how exactly do it?

I try to create file user.js at my profile folder with this line inside user_pref("browser.launcherProcess.enabled", false);

But it doesn't work cause still at every firefox update this switch return to true state.

附加的畫面擷圖

由 Gregory 於 修改

所有回覆 (13)

more options

That isn't a pref that you can modify. This pref is automatically set by the launcher process to reflect the current state. Even if it would stay then it won't have effect because the launcher process runs at a very early stage at startup and doesn't know about the actual profile that will be used. It merely configures how Firefox will run. If you want to affect the launcher process then this should probably be done via the Windows Registry or via environment variables.

有幫助嗎?

more options

I just want to make this switch FOREVER FALSE so never ask me the firefox privileges even i am the admin of the system to download a file at root of c drive that i have windows to.

All other browsers DOESN'T ask me privilege to download files at the root of drive c. So.....

And the only way make firefox DON'T ask me for privilege to download to root of drive c is this switch to turn it of(false) or i use the parameter "-no-deelevate" and i don't want to do that.

SO PLEASE TELL ME A WAY TO MAKE THIS SWITCH IS ALWAYS AT FALSE STATE.

Cause now at every firefox update i must MANUALLY turn this switch to false so it work and never ask me privilege.....


As i tallied you before ALREADY TRY: Create file user.js at my profile folder with this line inside user_pref("browser.launcherProcess.enabled", false);

but doesn't work cause again at the latest update need to switch it to false AGAIN.

由 Gregory 於 修改

有幫助嗎?

more options

You can try to lock this pref via the autoconfig.cfg file.

//
lockPref("browser.launcherProcess.enabled", false);

有幫助嗎?

more options

DON'T show me links with guides.

Please if you can tell me what file create and what text i write inside it to do this i want.

This switch ALWAYS stay at FALSE.

有幫助嗎?

more options

I create at the folder C:\Program Files (x86)\Mozilla firefox\defaults\pref the "autoconfig.js" file and inside of this file i add these lines:

pref("general.config.filename", "fitsman.cfg");

pref("general.config.obscure_value", 0);

As the guide shows.

Now at the next step where i must create the 2nd file "firefox.cfg" and what i must write inside this file for the switch ALWAYS STAY FALSE.

由 Gregory 於 修改

有幫助嗎?

more options

You can use the autoconfig.cfg file in the Firefox installation folder to initialize (set/lock) preferences and run privileged JavaScript code.

To use Autoconfig, place two files into the Firefox directory.

  • on Windows, they go in the same directory where Firefox is installed

The autoconfig.js file that specifies to use autoconfig.cfg is placed into the "defaults\pref" directory where the channel-prefs.js file is located.

//
pref("general.config.filename", "autoconfig.cfg");
pref("general.config.obscure_value", 0);

The autoconfig.cfg file is placed at the top level of the Firefox directory where the Firefox .exe file is located.

  • autoconfig.cfg and autoconfig.js need to start with a comment line (//)
  • autoconfig.js needs to use Unix line endings (LF instead of CR/LF), so you need an editor that supports this (Notepad++)

You can paste this data URI in the location bar and press Enter and save the file as autoconfig.js

data:application/octet-stream;base64,Ly8KcHJlZigiZ2VuZXJhbC5jb25maWcuZmlsZW5hbWUiLCAiYXV0b2NvbmZpZy5jZmciKTsKcHJlZigiZ2VuZXJhbC5jb25maWcub2JzY3VyZV92YWx1ZSIsIDApOwo=

You can paste this data URI in the location bar and press Enter and save the file as autoconfig.cfg

data:application/octet-stream;base64,
Ly8KbG9ja1ByZWYoImJyb3dzZXIubGF1bmNoZXJQcm9jZXNzLmVuYWJsZWQiLCBmYWxzZSk7

(if you want to inspect the files then replace data:application/octet-stream; with data:text/plain;)

有幫助嗎?

more options

I do it and now the switch is locked. Now never need again to change this switch to false it will be always false correct?

NICE. THANKS.

有幫助嗎?

more options

Edit:

No it doesn't work AT ALL.

Yes it's locked this switch but when you update the firefox even it was locked and show false AGAIN MUST SWITCH IT TO FALSE MANUALLY TO WORK SO ALL THESE WAS FOR NOTHING......

So all these it was really for NOTHING cause now cause the switch is off i must delete these two files so it will unlock and i can switch it back to false so......

由 Gregory 於 修改

有幫助嗎?

more options

Well, it appears from your what you tried so far that you can't do this within Firefox, so you would have to check the Windows Registry to see what is stored in the registry and even that might not work if the launcher is run automatically when Firefox is updated.
I'm not on Windows and can't help you further to investigate this.
You can try the sub Redit Firefox forum.

有幫助嗎?

more options

Really this is your answer? You simply pass me to reddit????

I believe THIS is was the official community support of firefox NOT REDDIT.

So even i try the lock option YOU SUGGEST and don't worked you don't have any other ideas / suggestion?????

And HOW IT WINDOWS ISSUE and this is happening at EVERY FIREFOX UPDATE AND NOT WINDOWS UPDATE.

So how it can be window issue one parameter/switch that reset at every firefox update???????

AGAIN THE THIS SWITCH WAS RESET AT EVERY FIREFOX UPDATE NOT WINDOWS OR ANY OTHER UPDATE SO..........

由 Gregory 於 修改

有幫助嗎?

more options

Hi,

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers, who are doing their best to help you.

What is the purpose for you change that about: config pref? Maybe we can solve this problem a different way.

有幫助嗎?

more options

I mention at the first post why I want that. Please read it.

有幫助嗎?

more options

Seburo said

What is the purpose for you change that about: config pref? Maybe we can solve this problem a different way.

Gregory said

I mention at the first post why I want that. Please read it.

From Gregory, at /questions/1294519/#answer-1331876 I just want to make this switch FOREVER FALSE so never ask me the firefox privileges even i am the admin of the system to download a file at root of c drive that i have windows to. All other browsers DOESN'T ask me privilege to download files at the root of drive c. So..... And the only way make firefox DON'T ask me for privilege to download to root of drive c is this switch to turn it of(false) or i use the parameter "-no-deelevate" and i don't want to do that.

See also Gregory's other thread for more information: https://support.mozilla.org/en-US/questions/1293294 firefox 78.0.1 ask privillenges to download files at c:

由 AliceWyman 於 修改

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題