搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox Stutter every 10 seconds (not sessionstore related ?)

  • 7 回覆
  • 1 有這個問題
  • 35 次檢視
  • 最近回覆由 aramirg

more options

Hello,

I recently had to switch back to my laptop and noticed that firefox is micro-stuttering (missing a couple of frame at worse) at a somewhat regular interval. Which is very noticable and head-ache inducing when watching a youtube video.

I tried to disable every plugins that I have, switching to a new profile, setting browser.sessionstore.max_tabs_undo and browser.sessionstore.max_windows_undo to 0, closing everything in the background, clearing cookies caches and etc.

Nothing worked, I noticed that disabling window's "Hardware-Accelerated GPU Scheduling" helped. With it on I've got a very regular micro stutter (every 10 seconds) whereas with it turned off I "only" get a microstutter once every 20/30 ish seconds. Therefore I suspect some shenanigans with optimus drivers but I don't know for sure how to confirm. I tried to force firefox to use the integrated gpu with nvidia pannel but it didn't help.

I would have capture a video to show off the problem but everytime I start recording (with lenovo's nerve sense capture software) the problem totally disappears !

Anyone have any ideas about what could be happening / how to diagnose more precisely the problem ? Thanks for reading.

specs :Windows 10 (x64), Firefox 78.0.1 (x64), Intel Core i5-7300HQ, optimus GPUS : Intel HD Graphics 630 + NVIDIA GeForce GTX 1060 (Max-Q)

所有回覆 (7)

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox.
Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode
Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

No safe mode doesn't change anything.

more options

Wait ... now it seems to be working .... I haven't done anything else beside trying out "safe mode" ... I'll report back if it's just a strike of luck and the problem comes back ...

more options

I have problem with youtube. It worked fine but few weeks ago it started to lose frames in youtube videos. 1080p 60fps means regular losing frames while it was working fine for constant few months before. Updates ruin firefox users experiences...

由 Piterk 於 修改

more options

Piterk Make sure your software is up to date.

more options

Well ... nevermind it's back to its stuttering state....

more options

I gave Chromium (CentBrowser) and it is also micro stuttering.... So firefox is probably not to blame here.