搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I remove search suggestions listed below address bar when I start to type?

  • 5 回覆
  • 1 有這個問題
  • 22 次檢視
  • 最近回覆由 JudEric

more options

Windows 7SP1. With the Firefox 78.0.1 update, search with Amazon.com, You Tube, Facebook, Reddit, Wikipedia and Twitter appear below the address bar when I start to type the url. I only have as default DuckDuckGo and Start Page HTTPS selected in options, and no alternatives.

I saw the one reply to this issue to use the about:config, browser.urlbar.oneOffSearches, change to false. This did not work.

Why has this been done? I don’t want them and I don’t use them. How do I get rid of this?

被選擇的解決方法

Hi JudEric, if you do not want a list to drop down automatically, there is a new checkbox for that on the Options page, under Privacy & Security, Address Bar:

If you decide to continue using the automatic list, you can clean it up. Firefox should fill up the list with frequently visited URLs after you clear out unwanted items, although this might take a little time to accumulate. Here's how:

Open about:newtab or about:home to display the Top Sites list. You can remove unwanted "Top Sites" by hovering your mouse over them, clicking the menu button that appears, and using either unpin (to let the site float back into a frequency-based order) or dismiss if you never want to see it. More info: Customize the New Tab page.

Note: If the Top Sites section is missing from the Firefox Home / news tab page you can turn it back on: Hide or display content in New Tab

從原來的回覆中察看解決方案 👍 1

所有回覆 (5)

more options

An easy way to remove this is to go to the Search section of the Firefox settings and removing all unwanted One-Click Search Engines.

有幫助嗎?

more options

Could you clarify what is in the drop-down? What I mean is, you mentioned that you started typing a URL but perhaps you haven't started typing yet? The display changes between first clicking and then starting to type.

  • Clicking the bar: Firefox shows your first 8 Top Sites from the new tab page
  • Typing: Firefox shows matching suggestions from search, bookmarks, and history

I am attaching a screenshot of what I mean.

有幫助嗎?

more options

@Wesley Branton. Thank you but that did not solve my problem

@jsches2000. Sorry. It's when I click the address bar -- before-- I start typing like your top sites list. Didn't know what top sites list was. But that is what I meant. How do I get rid of those search suggestions when I just click the address bar.

有幫助嗎?

more options

選擇的解決方法

Hi JudEric, if you do not want a list to drop down automatically, there is a new checkbox for that on the Options page, under Privacy & Security, Address Bar:

If you decide to continue using the automatic list, you can clean it up. Firefox should fill up the list with frequently visited URLs after you clear out unwanted items, although this might take a little time to accumulate. Here's how:

Open about:newtab or about:home to display the Top Sites list. You can remove unwanted "Top Sites" by hovering your mouse over them, clicking the menu button that appears, and using either unpin (to let the site float back into a frequency-based order) or dismiss if you never want to see it. More info: Customize the New Tab page.

Note: If the Top Sites section is missing from the Firefox Home / news tab page you can turn it back on: Hide or display content in New Tab

有幫助嗎?

more options

jscher2000 Thank you so much. That works. I'm so grateful.

Thank you for all this information. I can use all the help I can get.  :))

Have a great 4th of July!!!!!!

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題