搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Multi-Account Containers enabled, but no option to actually use them

  • 6 回覆
  • 1 有這個問題
  • 6 次檢視
  • 最近回覆由 mozilla125

more options

I've installed Firefox Multi-Account containers but I don't have either the shortcut in the upper right corner, nor the option to open a link in a new container (see screenshots attached). I've removed and added the add-on several times as well as doing clean installs of Firefox. Nothing is allowing me to use containers, though it shows installed.

I have made no changes to the default preferences (wanted to get this working before tweaking) and the only other add-ons I have are NoScript and YouTube Flash Player by Maxime RF. Removing either or both of those has no impact on my problem, as far as I can tell. Enable Container Tabs is checked (and grayed out) in Preferences, as the add-on requires it.

I'm on Firefox 77.0.1 (64bit) Clean install of pop!_OS 20.04 LTS

This is immensely frustrating, so any help would be appreciated!

附加的畫面擷圖

被選擇的解決方法

mozilla125 said

Also, I'm not running private windows. This is a normally opened Firefox instance.

Hmm, your screenshot of the right-click context menu suggests otherwise because it doesn't offer the option of opening a link in a regular window, only a private window.

Do you have this setting on the Preferences page:

  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security, and then scroll down to the History section.

Either of these will invoke automatic private browsing:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"
從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options

hello mozilla125,

follow the steps:

  • Install the Firefox Multi-Account Containers extension from the Mozilla Add-ons website.
  • To open Containers, look for the Containers icon in the Firefox toolbar:
  • Click on it and select the container you want to open.

for more information visit the given link: ([https://support.mozilla.org/en-US/kb/containers] )

tell me its help.

Thank you and Regards,

Arman

有幫助嗎?

more options

Hi mozilla125, I have a guess.

If you look at the icons following the four extension titles, you'll see one of them is not like the others: Multi-Account Containers doesn't show the purple mask icon indicating it is enabled to run in private windows. I don't know whether that is because it CAN'T run in private windows, or just isn't enabled to run in private windows. Either way, if you are using private windows, you can try enabling it in private window as follows:

  • Click the extension's title to open its Details page
  • Scroll down to the row with "Run in Private Windows" and click the radio button for Allow

Any improvement?

有幫助嗎?

more options

See attached. There is no option to turn that functionality on. Also, I'm not running private windows. This is a normally opened Firefox instance.

jscher2000 said

Hi mozilla125, I have a guess. If you look at the icons following the four extension titles, you'll see one of them is not like the others: Multi-Account Containers doesn't show the purple mask icon indicating it is enabled to run in private windows. I don't know whether that is because it CAN'T run in private windows, or just isn't enabled to run in private windows. Either way, if you are using private windows, you can try enabling it in private window as follows:
  • Click the extension's title to open its Details page
  • Scroll down to the row with "Run in Private Windows" and click the radio button for Allow
Any improvement?

由 mozilla125 於 修改

有幫助嗎?

more options

選擇的解決方法

mozilla125 said

Also, I'm not running private windows. This is a normally opened Firefox instance.

Hmm, your screenshot of the right-click context menu suggests otherwise because it doesn't offer the option of opening a link in a regular window, only a private window.

Do you have this setting on the Preferences page:

  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security, and then scroll down to the History section.

Either of these will invoke automatic private browsing:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"

有幫助嗎?

more options

Containers do not work in private browsing mode, so if you use PB mode then that would explain it.

有幫助嗎?

more options

Jscher2000 - thank you for the explanation. I didn't connect that setting with forcing a private window. That solved my problem - thanks!

jscher2000 said

mozilla125 said

Also, I'm not running private windows. This is a normally opened Firefox instance.

Hmm, your screenshot of the right-click context menu suggests otherwise because it doesn't offer the option of opening a link in a regular window, only a private window.

Do you have this setting on the Preferences page:

  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security, and then scroll down to the History section.

Either of these will invoke automatic private browsing:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題