搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

New tab with external app

more options

Hi everyone, I would like to know how to configure Firefox to open a new tab when I click on a link with an other app e.g : I click the link in Microsoft Word the link open in the last tab of Firefox.

Can you tell me how to configure Firefox please. Thanks a lot.

被選擇的解決方法

Hi buissonthomas, can you check the following setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste neww and pause while the list is filtered

(3) Review/Adjust the preferences as follows:

For external links, focus especially on (C):

(A) browser.link.open_newwindow - for links in Firefox tabs

This is the one that has a checkbox on the Preferences page:

  • 3 = divert new window to a new tab (default)
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browse.link.open_newwindow.restriction - for links in Firefox tabs

By default, if a page sets width, height, or toolbars for a popup, Firefox will let it be a separate window. To force those into a tab as well, you can change this preference to 0:

  • 0 = apply the setting under (A) to ALL new windows (even script windows with features)
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default)
  • 3 = open external links in a new tab in the last active window <== try this
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page <== make sure you do not have this setting

To return to normal if things go haywire, there's an arrow-like reset button at the right end of each of those rows if it has a non-default value.

Success?

從原來的回覆中察看解決方案 👍 1

所有回覆 (2)

more options

選擇的解決方法

Hi buissonthomas, can you check the following setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste neww and pause while the list is filtered

(3) Review/Adjust the preferences as follows:

For external links, focus especially on (C):

(A) browser.link.open_newwindow - for links in Firefox tabs

This is the one that has a checkbox on the Preferences page:

  • 3 = divert new window to a new tab (default)
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browse.link.open_newwindow.restriction - for links in Firefox tabs

By default, if a page sets width, height, or toolbars for a popup, Firefox will let it be a separate window. To force those into a tab as well, you can change this preference to 0:

  • 0 = apply the setting under (A) to ALL new windows (even script windows with features)
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default)
  • 3 = open external links in a new tab in the last active window <== try this
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page <== make sure you do not have this setting

To return to normal if things go haywire, there's an arrow-like reset button at the right end of each of those rows if it has a non-default value.

Success?

由 jscher2000 於 修改

有幫助嗎?

more options

Thanks a lot, it works ! Have a nice week.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題