搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Specific website won't open in Firefox but will open in other browsers.

more options

My website, www.orthodoxdelmar.org, won't load in Firefox but will load in other browsers. I get a white screen in Firefox. I haven't had a problem with any other website.

I've tried going directly to specific pages on the site. I've exited and restarted Firefox. I've restarted my laptop. I can't find any setting where I might have accidentally blocked the page.

I'm running Firefox 77.0.1 (64 bit) on Windows 10. Laptop only 4 months old.

What am I missing?

Thank you.

附加的畫面擷圖

被選擇的解決方法

My guess is DuckDuckGo Privacy Essentials.

從原來的回覆中察看解決方案 👍 1

所有回覆 (16)

more options

hello,

Clear all cookies, site data and cache:

  • Click the menu button. and select Options. Preferences.
  • Select the Privacy & Security panel and go to the Cookies and Site Data section.
  • Click the Clear Data… button. The Clear Data dialog will appear. ...
  • Click Clear.

for more information:

[https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox]

goto safe mode:

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled. If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode

(you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

[mode/#:~:text=Press%20the%20Windows%20key%20%2B%20R,Start%20in%20Safe%20Mode%20button.&text=Hold%20down%20the%20SHIFT%20key,Firefox%20shortcut%20on%20your%20desktop.]

I hope resolve your problem then reply back to me,

Thank you

有幫助嗎?

more options

Hi khveraacker, is this a recent change, was Firefox working normally with the page before?

This Weebly page is in a frame. Firefox will usually load framed sites, so it should work. However, to separate the issue of being in a frame from the actual site, could you try this test:

right-click the center of the page > click This Frame > click Open Frame in New Tab

That should launch https://orthodoxdelmar.weebly.com/ in a new tab. Does that site work for you outside of the frame?

有幫助嗎?

more options

jscher2000 said

Hi khveraacker, is this a recent change, was Firefox working normally with the page before? This Weebly page is in a frame. Firefox will usually load framed sites, so it should work. However, to separate the issue of being in a frame from the actual site, could you try this test: right-click the center of the page > click This Frame > click Open Frame in New Tab That should launch https://orthodoxdelmar.weebly.com/ in a new tab. Does that site work for you outside of the frame?

_____ Thank you. This is a recent problem. I was able to open the page up to a couple of days ago. I've been updating the site on Weebly this week and periodically checking to see how the changes looked. Yesterday the page wouldn't open.

I opened the frame in the new tab as you suggested, but still got a white page. When I clicked the link that includes the full weebly address, it opens just fine. But I'd like to open it with our domain name.

I have not yet tried Arman's suggestions, though I cleared all my cookies and cache a couple of days ago.

由 khveraacker 於 修改

有幫助嗎?

more options

Hello,

You can clear cookies and site data for that particular website.

Click on menu icon. Click on options. In left pane you will find Privacy & Security menu , click on it. In this menu you will find an option Cookies and Sites Data. In this option, you will find Manage data click on it. A popup box will be open, choose your website from that list and click on Remove Selected.

Hope it helps. Thank You.

有幫助嗎?

more options

When a site is under heavy development, stuck files in the cache can be a problem, so that's what I'd try first before deleting other data: How to clear the Firefox cache.

有幫助嗎?

more options

I first tried clearing the data/cookies/cache for that page only, as Shashank suggested. That didn't work. Then I cleared it all and restarted firefox; that didn't work either. I am still not able to open the page from our own name, though I can if I use the weebly address.

However, it did open properly in safe mode. My extensions are shown in the image. None of them are new.

由 khveraacker 於 修改

有幫助嗎?

more options

If its opening in safe mode, it clearly indicates that some of your add-on is blocking your page. Just Disable all add-ons or Try Refreshing the browser.

  • To do this, click the menu button at the top right corner of the Firefox window.
  • Click the “Help” option near the bottom of the menu.
  • Click the “Troubleshooting Information” option in the Help menu.
  • Click the “Refresh Firefox” button at the top right corner of the Troubleshooting Information page.
  • You’ll be warned that this will remove your browser add-ons, reset your customizations, and revert other browser data to the default settings. Click “Refresh Firefox” to confirm you want to make these changes.

If it doesn't solved your problem, then feel free to ask in Reply Section. Thanks for raising your question in Mozilla Support Forum.

由 Shashank Shekhar 於 修改

有幫助嗎?

more options

選擇的解決方法

My guess is DuckDuckGo Privacy Essentials.

有幫助嗎?

more options

jscher2000 said

My guess is DuckDuckGo Privacy Essentials.

Yes, that was it. I disabled it and was able to open the website. It's not a new add-on, but perhaps they updated it. I'll look into it from that end.

Thank you!

有幫助嗎?

more options

I have the same problem except on a mac. My website homepage won't load fully after I've logged in. But it does load in a private window and in Safari. I've safe started firefox, cleared cache and cookies, restarted computer. All the ideas mentioned above. To no avail.

DuckDuckGo appears as a recommended add-on in my add-ons manager page, but I've never installed or enabled it.

Any more ideas?

有幫助嗎?

more options

Hi Najib Joe Hakim, I'm not sure what you've tried so far of the many suggestions in this thread.

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking/Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Enhanced Tracking Protection in Firefox for desktop (before Firefox 70: Content blocking).

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

有幫助嗎?

more options

Hi, Jscher - Thanks for checking in!

I've done all of the above that you suggested and more: Disabled add-ons including the Firefox Content Blocking; Cleared cache and all cookies and all history; Restarted the computer; Tested in safe mode.  : /

Anything else I might try? (Since there is no problem if I login to my website with Safari, the problem must be something gone wrong in Firefox.)

有幫助嗎?

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

有幫助嗎?

more options

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

有幫助嗎?

more options

Hi, Cor-el

I tried both suggestions you made but to no avail.

How about re-installing Firefox? Could that work? If so, how would I do that and protect my bookmarks, etc.?

有幫助嗎?

more options

Seems the problem is spreading. Now my FB page won't scroll.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題