搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Widevine Error on Developer Edition

more options

Hi, when I try to watch a video on Prime Video I get error saying that the plugin crashed.

I asked a similar question on Reddit here and now I’m quite sure that the plugin is the Widevine plugin.

I tried everything I’ve been suggested but still I can’t solve this issue.

Does anyone have any other tips? Thanks

被選擇的解決方法

Hi, it's me. Sorry for the late reply but I found the solution.

It's kind of embarrassing but all it takes to make it works is to turn off the antivirus. I feel dumb for not having tried it before.

If you don't want to turn it off, you can add firefox to the exclusions of the antivirus; I think most of the AVs have this feature.

Thanks everyone for the help.

從原來的回覆中察看解決方案 👍 0

所有回覆 (8)

more options

Hi Alessandro, Widevine is required by Netflix and Amazon Prime.

Does it make any difference if you disable DRM on the Preferences page? You can check that here:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type drm and Firefox should filter to the "Digital Rights Management" section.

Uncheck the box for "Play DRM-controlled content".

Any difference?

If that doesn't help, reinstalling Widevine might, but I'm not sure how to do that. Since Widevine is installed per profile, you might check whether creating a new profile works around it. In that case, perhaps we could transplant the Widevine folder (gmp-widevinecdm) from new to old.

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like Nov2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do videos work any better in the new profile?

I guess we don't know at what point Firefox will install Widevine, so perhaps this isn't a useful test...

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

有幫助嗎?

more options

Unfortunately, the Widevine Content Decryption Module plugin never shows up in the list of plugins contained in the information that this support website collects for your system details, so I can't actually see what version you have.

My system shows 1.4.8.1008 as the latest version that was last updated on June 18, 2018.

The first thing to try would be to uncheck the Play DRM-controlled content option in the Digital Rights Management (DRM) Content section of the General tab, restart Firefox and then check that option again.

You also have blocking addons installed in Firefox, which may be preventing Netflix from running properly. You can try Firefox Safe Mode to see if the issue goes away when you running in that mode. If it does, it's likely something to do with an addon installed on Firefox.

Hope this helps.

有幫助嗎?

more options

If I disable "Play DRM-controlled content", I get the same yellow bar telling me to enable it, otherwise the video won't play.

Creating a new profile didn't help, even in safe-mode.

I tried to manually uninstall Widevine by deleting the "gmp-widevinecdm" folder in the profile path. After restarting the browser, the yellow bar says that Widevine is being installed but I have the same problems.

My Widevine version is 4.10.1582.2 by the way, that is the same of the plain firefox version (where everthing works fine).

EDIT: Netflix works, but Prime Video don't.

由 Alessandro 於 修改

有幫助嗎?

more options

Current Widevine should be 4.10.1582.2

  • Bug 1596874 - [Meta] Update Widevine to version 4.10.1582.2

Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components.

有幫助嗎?

more options

I've been having the same problem on my MacBook Air ever since I bought it 18 months ago. Unable to watch any videos yet I can watch live TV. Want to watch a show that aired on CBS last night but WideVineCDM crashes every time. Thanks for the suggestions; I'll try them.

有幫助嗎?

more options

My Widevine CDM version is 4.10.1196.0 and it still does not work.

有幫助嗎?

more options

選擇的解決方法

Hi, it's me. Sorry for the late reply but I found the solution.

It's kind of embarrassing but all it takes to make it works is to turn off the antivirus. I feel dumb for not having tried it before.

If you don't want to turn it off, you can add firefox to the exclusions of the antivirus; I think most of the AVs have this feature.

Thanks everyone for the help.

由 Alessandro 於 修改

有幫助嗎?

more options

I turned off my antivirus and Widevine CDM Still does not work. I can watch Netflix by using Safari, though. I dislike Safari, so I would truly like a fix to this problem with FireFox.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題