Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Can't login to Facebook: "The page isn’t redirecting properly"

  • 12 回覆
  • 1 有這個問題
  • 44 次檢視
  • 最近回覆由 rperera00

more options

Hi: so, for the last couple weeks or so, I've been unable to login to Facebook. I think this may have occurred after updating to the then-latest version of Firefox, but I can't be sure of that. When I try to log in, I get this message:


The page isn’t redirecting properly

An error occurred during a connection to www.facebook.com.

This problem can sometimes be caused by disabling or refusing to accept cookies.


I've tried clearing Facebook's cookies, clearing all cookies/cache data, and then refreshing Firefox. None of this has helped. (Meanwhile, Facebook sends me a "Is this you?" e-mail every time I try to log in...) Currently using Windows 10, and the latest version of Firefox.

Any help would be very much appreciated!

All Replies (12)

more options

Hi rperera00, glad to see you on Mozilla Supprt Forum.

The best place to start is "the usual" --

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

Helpful?

more options

Hi there, thanks for the tip. Have tried clearing the cache and deleting cookies before, but tried it again through your suggested way. Gives me the same error, sadly...

Helpful?

more options

The best place to start is "the usual" --

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

   right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
   (menu bar) Tools > Page Info > Security > "View Cookies"
   click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button 

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help? Read this answer in context

Helpful?

more options

I am sure it must be a cookie problem.

Do you have the default cookie settings? See: Websites say cookies are blocked - Unblock them .

Helpful?

more options

Hi rperera00, If clearing cookies didn't help then It is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

   rename/remove cookies.sqlite (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder in case cookies.sqlite got corrupted. 

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

   Help -> Troubleshooting Information -> Profile Directory:
   Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder
   http://kb.mozillazine.org/Profile_folder_-_Firefox 

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

   https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox

Helpful?

more options

Yes, I believe so. "Standard" is selected, and Facebook is not listed under "Exceptions".

Helpful?

more options

I have regenerated this problem in my PC and found,

I deleted ALL the cookies and cleared the cache. I hope this makes it clearer.

It didn't work.

Switching to "Always use private browsing mode" did.

Thank You.

Helpful?

more options

ANAMIKA KUMARI: Sorry, what is it you're saying I should delete? I have tried the "Forget about this site" option for Facebook and it gives me the same error message when I try to log in: "The page isn’t redirecting properly

An error occurred during a connection to www.facebook.com.

   This problem can sometimes be caused by disabling or refusing to accept cookies. "

Helpful?

more options

Shashank Shekhar said

I have regenerated this problem in my PC and found, I deleted ALL the cookies and cleared the cache. I hope this makes it clearer. It didn't work. Switching to "Always use private browsing mode" did. Thank You.

Just tried setting it to "Always use private browsing mode" and alas, I'm getting the same error message once again. :(

Helpful?

more options

Hello rperera, Try this one also It might help you Do you have the default cookie settings? See: Websites say cookies are blocked - Unblock them.

Helpful?

more options

Himanshu prabhakar said

Hello rperera, Try this one also It might help you Do you have the default cookie settings? See: Websites say cookies are blocked - Unblock them.

Hi, I do have the default cookie settings, as mentioned above. "Standard" is selected, and no sites are blocked.

Helpful?

more options

Hi everyone! Just wanted to post and let people know that I think I've solved this problem, and it wasn't a Firefox problem after all. It was a Facebook issue - they changed some links around or something, which lead to an never-ending redirect loop.

https://support.google.com/chrome/thread/42116826?hl=en

To anyone who has this frustrating problem, if you check the advice "Aaron Smith 3297" had in this thread, that's what worked for me.

Many thanks to everyone here who tried to help me out. :)

Helpful?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題